Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-28-2001, 09:27 AM
Registered User
Join Date: Oct 2000
Posts: 27
On 1985 500sel- the AC/Defrost/vent works fine until the car
sets in the hot sun-then its dead. That is the AC compressor comes on but the blower does not engage. So it works fine on the way to work but not on the way home when it would be wonderful. Could it be the push button control and how does one get the face plate off to get to the pbc.
A simple fix would sure improve my life( car driven by frau)
Reply With Quote
Old 06-29-2001, 10:58 PM
Posts: n/a

My C220 has been doing the same thing for some time now. I replaced the push button control because it was going dead on me and the problem has been there ever since. I recently replaced the vacum box and still no difference. If you get some good information on what is causing the problem please let us know.


Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Intermittent Rough Operation Okiebenz Tech Help 2 05-21-2002 09:38 AM
Intermittent Rough Operation Okiebenz Diesel Discussion 3 05-20-2002 02:12 PM
Intermittent Cruise Control Operation, 1986 190E 2.3 5-Speed JimSmith Tech Help 3 08-29-2001 05:04 AM

All times are GMT -4. The time now is 09:27 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page