Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-26-2007, 11:54 PM
Brooklyn,NY
 
Join Date: Apr 2005
Location: Brooklyn,NY
Posts: 252
low power when hot 92 500sel

Hi guys,

My car 1992 500sel m119 172kml has low power when car warms up. Car starts to hesitate when coolant reaches 90 degrees and as it get hotter it gets worse. At around 100 degrees if i floor it it sounds like it floods the cylinders or maybe not enough gas. I dont know how to test it. Engine is very hot to work around. It seems to pick up rpms with stress even on idle. I suspect timing (which is electronic and it seems to change timing when i use a strobe light to check), tranny overload sensor that alters timing or fuel pump or fuel filter. Problem is so bad that if I have ac on and need to move when light turns green the car would barely move forward. People honk behind for me to move Intake makes a sound like those Maximas with cold air intakes when floored but my car doesnt move nowhere. Sounds like its about to stall but it doesnt. When its cold it picks up speed pretty well. Any thoughts? Could it be one of the ignition coils?

I have changed coolant temperature sensor, thermostat, water pump, spark plugs, cleaned wires, rotor caps and rotors.

Im stuck here.

Please help.

Thank you

__________________
1999 ML430 Silver 135k ml
Smoked LED taillights, Alpine in-dash DVD player, 12" sub, Pioneer components, 2 amps, 4200k HIDs, ML55 headlights, 20" rims, mirror LED blinkers

SOLD. 1996 E320 145k ml. Burgundy

SOLD but miss it everyday 1992 500sel Black
Chime buzzer mod,Alpine CD/MP3 player with stock amp,Euro headlights,S600 grill,20" rims, BEST CAR EVER!

SOLD. 1990 300E White
187k ml,smoked tails,Euro headlights,17rims,Intake,12" sub in first aid kit,alarm/autostart,buzzer mod

Reply With Quote
  #2  
Old 09-27-2007, 08:35 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Possibly start with basics.. compression & secondary ignition.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 09-27-2007, 08:40 AM
Brooklyn,NY
 
Join Date: Apr 2005
Location: Brooklyn,NY
Posts: 252
What is the proper procedure to check compression? I checked compression twice. Car was cold, I took out spark plugs, screwed in compression tester and cranked the engine few times. At first crank compression is low and it gets into normal range at second crank. Also If I crank the engine few times before I check compression, first crank reading is way higher. Am I doing it right?

What is the secondary ignition?

Thanks
__________________
1999 ML430 Silver 135k ml
Smoked LED taillights, Alpine in-dash DVD player, 12" sub, Pioneer components, 2 amps, 4200k HIDs, ML55 headlights, 20" rims, mirror LED blinkers

SOLD. 1996 E320 145k ml. Burgundy

SOLD but miss it everyday 1992 500sel Black
Chime buzzer mod,Alpine CD/MP3 player with stock amp,Euro headlights,S600 grill,20" rims, BEST CAR EVER!

SOLD. 1990 300E White
187k ml,smoked tails,Euro headlights,17rims,Intake,12" sub in first aid kit,alarm/autostart,buzzer mod

Reply With Quote
  #4  
Old 09-27-2007, 09:14 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Secondary ignition is plugs, wires, cap, rotor, coils...ect

I suggested the compression in lieu of checking the basic cam timing in case the timing chain has jumped.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #5  
Old 09-27-2007, 12:01 PM
david s poole
 
Join Date: Mar 2005
Location: dallas
Posts: 1,822
based on your description that as car gets hot power gets worse i would suspect the catalyst blocking up.easy check,remove the front 02 sensors and then drive.
__________________
David S Poole
European Performance
Dallas, TX
4696880422

"Fortune favors the prepared mind"
1987 Mercedes Benz 420SEL
1988 Mercedes Benz 300TE (With new evaporator)
2000 Mercedes Benz C280
http://www.w108.org/gallery/albums/A...1159.thumb.jpg
Reply With Quote
  #6  
Old 09-27-2007, 12:29 PM
W210 E300TD Newbie
 
Join Date: Mar 2007
Location: Houston, TX
Posts: 356
Mr. Poole has a good suggestion there, strange as it may sound. I had never seen a catalytic converter grind a car to a halt, until a few weeks ago -- when it happened to my parents in their S-class. It required dealer replacement (both of them, just to be on the safe side), and the car is back to running like a champ.

Cheers, John
__________________
'98 E300TD (W210) | Sold 6/09 with 205k and counting
'04 VW Touareg V10TDI
Reply With Quote
  #7  
Old 09-27-2007, 04:06 PM
Brooklyn,NY
 
Join Date: Apr 2005
Location: Brooklyn,NY
Posts: 252
Thanks a lot for replies,guys.
I have replaced a catalytic converter with another used one with 75kml on it. It made no improvement. But I am sure that my caps and rotors should be replaced because they are old too. I have them cleaned once already. Also I hear a slight clicking from one of the ignition coils. MB Doc suggest checking them too. I just noticed clicking from the coil today. Maybe that is the cause. Is there a way to check coils? It's funny but the car always had that low power than hot problem when I bought it 2 years ago.

Timing was checked twice by removing top covers and inserting pins into camshafts aligning vibration damper to 45 mark. My mechanic says timing is off but all marks line up. It's a strange problem.

__________________
1999 ML430 Silver 135k ml
Smoked LED taillights, Alpine in-dash DVD player, 12" sub, Pioneer components, 2 amps, 4200k HIDs, ML55 headlights, 20" rims, mirror LED blinkers

SOLD. 1996 E320 145k ml. Burgundy

SOLD but miss it everyday 1992 500sel Black
Chime buzzer mod,Alpine CD/MP3 player with stock amp,Euro headlights,S600 grill,20" rims, BEST CAR EVER!

SOLD. 1990 300E White
187k ml,smoked tails,Euro headlights,17rims,Intake,12" sub in first aid kit,alarm/autostart,buzzer mod

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:19 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page