Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-02-2007, 09:33 AM
TROVERMAN's Avatar
Registered User
 
Join Date: Oct 2003
Location: NH
Posts: 355
Interior Lights, plus exhaust smoke, w124

Hi everyone, here are two unrelated questions:

Since we got our 95 e320 wagon, the front lights only came on when the passenger door opened--I know, this is the seatbelt relay in the instrument cluster. For about a year now, the four rear lights on the pillars do not work. If the dash switch is left in the auto (door open, turn on) position, the lights remain on all the time, doors opened or closed. They also are slightly dimmer than if the dash switch is set to 'on.' How do I make them work right again? Bad ground? What do I check, and where? Thanks on that...

We have owned our car four some time now, buying it at 39k miles and it now has 107k on it. I noticed a pretty big cloud of blue smoke come from the exhaust upon starting up on a cold morning recently. It went away immediately. Why did it do this? Sometimes if you watch the exhaust closely while an assistant starts the car (mainly when warm) you see the slightest amount of black smoke a second or two after it starts and then nothing. ANy ideas here?

The car has had the headgasket job done and runs terrifically.

However, it did something else I didn't like recently. After a drive up a long hill to an apple orchard, the temp gauge was at about 115C and the electric fans were on. After making our purchases, the car would not restart. It cranked, fired, and died. It took 10-15 minutes of sitting and cooling before it started.

On another occasion it almost died in traffic (very hot day, car running hot). Fuel economy has also been off a little, but the 02 sensor was replaced at 60k miles.

Check Engine never lights up, even as part of the bulb check. How do I get codes on this OBD1 system?

Thanks

__________________
________________________
2002 Mercedes-Benz E320 4Matic
1995 Mercedes-Benz E320 Wagon
2005 Land Rover LR3 V8 SE
1999 Audi A8 4.2L quattro
Reply With Quote
  #2  
Old 10-04-2007, 08:14 AM
TROVERMAN's Avatar
Registered User
 
Join Date: Oct 2003
Location: NH
Posts: 355
No one knows how to retrieve codes on pre OBD Benzes? Or knows about the interior lighting?

bump.

__________________
________________________
2002 Mercedes-Benz E320 4Matic
1995 Mercedes-Benz E320 Wagon
2005 Land Rover LR3 V8 SE
1999 Audi A8 4.2L quattro
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:59 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page