Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-04-2007, 03:10 PM
Registered User
 
Join Date: Jul 2004
Location: NC
Posts: 1,140
Sick of this! Fixed my power/mileage loss, and then it comes BACK

97 c230.....cleaned MAF, MAF has 60k on it 2 years after replacement. Car has 163k miles. Power and mileage came back 100% within 4 days of cleaning, and then a couple days ago I was under WOT from a stop and somewhere about 4000rpm, 1st gear, I felt a stumble. Power and mileage immediately back in the toilet. Like I hit a brick wall.

What gives?

__________________
former: 83 300D, 97 C230, 93 400E

current: 08 C300 Luxury , 92 500SL
Reply With Quote
  #2  
Old 10-04-2007, 04:00 PM
dpetryk's Avatar
Electrons can do anything
 
Join Date: Sep 2001
Location: Houston, Texas
Posts: 1,072
Its a Benz. They need a lot of maintenance.
__________________
I got too many cars!! Insurance eats me alive. Dave

78 Corvette Stingray - 3k
82 242 Turbo Volvo - Manual - 270k
86 300e 5 speed manual - 210k
87 420sel - 240k
89 560sl - 78k
91 420sel - 205k
91 560sel - 85k
94 GMC Suburban - 90k
97 Harley Davidson Heritage Softail - 25k
00 GMC Silverado 1 ton 30k
Reply With Quote
  #3  
Old 10-04-2007, 04:17 PM
Registered User
 
Join Date: Jul 2004
Location: NC
Posts: 1,140
Quote:
Originally Posted by dpetryk View Post
Its a Benz. They need a lot of maintenance.
And mine gets more than it's fair share of love.

Any sugestions? MBDOC?
__________________
former: 83 300D, 97 C230, 93 400E

current: 08 C300 Luxury , 92 500SL
Reply With Quote
  #4  
Old 10-04-2007, 04:47 PM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Most likely a mass air flow sensor failure.

Cleaning rarely fixes the sensor, only a temporary condition.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #5  
Old 10-04-2007, 04:58 PM
Registered User
 
Join Date: Jul 2004
Location: NC
Posts: 1,140
Doc, you confirmed what my subconscious musings were trying to ignore.

A bit frustrating to only get 2 years out of the thing though.
__________________
former: 83 300D, 97 C230, 93 400E

current: 08 C300 Luxury , 92 500SL
Reply With Quote
  #6  
Old 10-04-2007, 07:05 PM
Registered User
 
Join Date: Sep 2004
Location: DFW / Collin County Texas
Posts: 1,882
I cleaned my MAF once and it only worked well for a few days before the stumble and poor mileage returned. I bought a new one and the problems were gone completely. I think cleaning just gives you a 50/50 chance of resolving the issue. In many cases you end up buying a new one anyway.

It's alright, just keep the old one in the trunk as a spare - they do occasionally go out completely, in which case your faulty sensor is better than none at all...

__________________
08 W251 R350
97 W210 E320
91 W124 300E
86 W126 560SEL
85 W126 380SE Silver
85 W126 380SE Cranberry
79 W123 250
78 W123 280E
75 W114 280
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:12 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2024 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page