Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-10-2001, 05:33 PM
Del Ray
Posts: n/a
After replacing the compressor on a 300E the clutch will not stay engaged unless you hold engine rpm above 1500 rpm. once the compressor shuts off it will not reengage untill you turn ignition off and restart the vehicle. A/C opperated fine before replacement but compressor was noisy. Could this have anything to do with the sensor on the back of the compressor and if so how can I test it?
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Replacing a/c comp. clutch with compressor in vehicle? The Warden Diesel Discussion 8 08-19-2004 06:34 PM
High Idle 300E -88 (Have preformed search) Sundman Tech Help 28 06-21-2004 03:47 AM
turn signal bulb out? and rough idle on 300e dirtysocks Tech Help 13 04-23-2004 01:30 AM
300E A/C - please help diagnose 300EE320 Tech Help 10 08-29-2002 11:52 AM
A/C does not cool at idle jayhawk Tech Help 8 07-16-2001 01:01 PM

All times are GMT -4. The time now is 01:46 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page