Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-07-2007, 06:35 PM
davidmash's Avatar
Supercalifragilisticexpia
 
Join Date: Mar 2002
Location: Arlington, TX
Posts: 24,295
190E 16v Idle issues/questions

I tried to search but way to much stuff came back and I could not find anything that addressed my issues.

My 190 is having idle issues and has been for quite some time.

First issue is a hight idle. In park it hovers around 1000-1100 and in drive down to about 800-900. I have been told this is with in the high end of normal but it seems too high to me.

Second, on start up (cold or hot engine and out side temp does not seem to matter) it will sometimes stick at around 2k rpm till I tap the throttle and then it will settle down to 'normal' at around 1100 or so.

What components control the idle? can someone give me some things I can start looking at to try and get it down to normal? What the heck is normal anyway?

I'm not very good at electronics but I am willing to learn if someone an give me some pointers.

Thanks

David.

__________________
Sent from an agnostic abacus

2014 C250 21,XXX my new DD ** 2013 GLK 350 18,000 Wife's new DD**

- With out god, life is everything.
- God is an ever receding pocket of scientific ignorance that's getting smaller and smaller as time moves on..." Neil DeGrasse Tyson
- You can pray for me, I'll think for you.
- When you understand why you dismiss all the other possible gods, you will understand why I dismiss yours.
Reply With Quote
  #2  
Old 12-08-2007, 12:34 AM
Registered User
 
Join Date: May 2005
Posts: 84
high idle

clean the icv first and see if the idle comes down if not check for vacuums leaks, these are the two most common reasons for high idle problems. hope this helps.
Joe
Reply With Quote
  #3  
Old 12-08-2007, 01:22 AM
davidmash's Avatar
Supercalifragilisticexpia
 
Join Date: Mar 2002
Location: Arlington, TX
Posts: 24,295
What's an "icv"?
__________________
Sent from an agnostic abacus

2014 C250 21,XXX my new DD ** 2013 GLK 350 18,000 Wife's new DD**

- With out god, life is everything.
- God is an ever receding pocket of scientific ignorance that's getting smaller and smaller as time moves on..." Neil DeGrasse Tyson
- You can pray for me, I'll think for you.
- When you understand why you dismiss all the other possible gods, you will understand why I dismiss yours.
Reply With Quote
  #4  
Old 12-08-2007, 11:59 AM
Registered User
 
Join Date: May 2005
Posts: 84
idle control valve
Reply With Quote
  #5  
Old 12-08-2007, 03:52 PM
davidmash's Avatar
Supercalifragilisticexpia
 
Join Date: Mar 2002
Location: Arlington, TX
Posts: 24,295
OK, now does anyone know where it is and what it looks like?

Also, a few things I did not mention that may or may not be related. I have noticed that when I back my car into the garage and go straight to Park, I have noticed that sometimes the drive train will get loaded up. When I pull out of Park, the tranny will "pop" out of gear. Also, hwne I put the car in neutral or in Park, the engine will rev up a bit 1200-1300 for a second or two and then settle back down to 1000 or so.

Thanks again.
__________________
Sent from an agnostic abacus

2014 C250 21,XXX my new DD ** 2013 GLK 350 18,000 Wife's new DD**

- With out god, life is everything.
- God is an ever receding pocket of scientific ignorance that's getting smaller and smaller as time moves on..." Neil DeGrasse Tyson
- You can pray for me, I'll think for you.
- When you understand why you dismiss all the other possible gods, you will understand why I dismiss yours.
Reply With Quote
  #6  
Old 12-09-2007, 05:49 PM
davidmash's Avatar
Supercalifragilisticexpia
 
Join Date: Mar 2002
Location: Arlington, TX
Posts: 24,295
I am looking in my Shop Manual (Grey with blue stripe) and I found something called

Idle speed air distributer

Is that what I am looking for? This manual is for a 102 engine but it does not have alotr of stuff for the 034 engine for a 16v.

Thanks
__________________
Sent from an agnostic abacus

2014 C250 21,XXX my new DD ** 2013 GLK 350 18,000 Wife's new DD**

- With out god, life is everything.
- God is an ever receding pocket of scientific ignorance that's getting smaller and smaller as time moves on..." Neil DeGrasse Tyson
- You can pray for me, I'll think for you.
- When you understand why you dismiss all the other possible gods, you will understand why I dismiss yours.
Reply With Quote
  #7  
Old 12-10-2007, 12:50 AM
Registered User
 
Join Date: Jul 2006
Posts: 39
190E 16v Idle issues

I had the same type of problem on my 190.
The fix for me was to take off the throttle position switch ( this gives a signel when the throttle is either open or closed).
It can be found in the front side of the throttle body and has 3 wires coming from it that go to the CIS module.
To check it disconnect the 3 pin connector at the front side of the CIS control valve/fuel distributor block and connect a DVM on ohms and you should have continuity accros 2 of the pins with the throttle closed and the other two when open, can't remember which pins but one pin is common an the other two are for open or closed.
If you cannot get continuity every time at open or closed then the switch is faulty.
The fix is to buy a new switch or fix the old one, it can be fixed by prying the top of housing off and cleaning the inside first then bend the copper strip that moves with the throttle shaft so that it will always touch the 2 contacts at either end of the housing, make sure that they are clean.
Chuck
Reply With Quote
  #8  
Old 12-10-2007, 12:17 PM
david s poole
 
Join Date: Mar 2005
Location: dallas
Posts: 1,822
sounds like you have throttle linkage sticking issues[if you have to blip throttle to make idle come down]this in conjunction with throttle switch could be your major prob.
__________________
David S Poole
European Performance
Dallas, TX
4696880422

"Fortune favors the prepared mind"
1987 Mercedes Benz 420SEL
1988 Mercedes Benz 300TE (With new evaporator)
2000 Mercedes Benz C280
http://www.w108.org/gallery/albums/A...1159.thumb.jpg
Reply With Quote
  #9  
Old 12-10-2007, 02:38 PM
Jay Gibbs's Avatar
Registered User
 
Join Date: Jul 2000
Location: US
Posts: 318
I had a 16V, and a few friends who did too...

We ALL had some sort of idle problem very similar (or nearly identical) to what you describe. The idle control valve is often the culprit. Try cleaning as was previously described. You may need to replace it ultimately though.

I also had my fuel distributor cleaned as well and alot of crud was found inside.

Over the years I owned it, I don't know that it EVER really idled "perfectly" for me...

J.G.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:48 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page