Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-14-2001, 03:02 PM
Registered User
Join Date: Mar 1999
Location: Williamsburg,VA, USA
Posts: 106
The air pump is making a loud squeal and the clutch is very hot after just a couple minutes of running the engine. Assuming I need a new clutch. I took the belt off,haveen't got the pump off yet to troubleshoot. Will it hurt to operate the car for a couple weeks til I get around to fixing it?
Reply With Quote
Old 07-14-2001, 09:52 PM
Posts: n/a
Actually, mine was not operative and did not even have a belt to it when I removed the engine for work. I removed the entire 'boat anchor' altogether upon reinstallation. The air cleaner body now has an extra opening for air! Absolutely no problems. ('81 380sl)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Checklist: PS Pump Re-Seal EricSilver Tech Help 29 07-15-2007 11:35 AM
380SL Fuel Pump Replacement Causes Rough Idle & Other Problems? ezrider SL Forum 8 03-14-2004 12:12 PM
92 300E air pump RDMosley Tech Help 11 04-09-2003 06:04 PM
need advice for air pump clutch/pully Bill '90 300E Tech Help 3 05-15-2002 09:30 PM
M103 Air Pump Hell someguyfromMaryland Tech Help 5 05-20-2001 07:58 AM

All times are GMT -4. The time now is 06:58 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page