Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-15-2007, 11:52 PM
Registered User
 
Join Date: Dec 2007
Posts: 31
Jump Start disaster

I recently purchased a 1992 300D. During a rigorous cleaning, doors left open for good portion of the day, I managed to drain the battery. I jump started the vehicle and now the tachometer doesnít work and the ABS light is illuminated. Fuse D1 went out. I replaced the fuse but that didnít help the ABS or tach issue. Any ideas? I hope something else isnít lingering L


Reply With Quote
  #2  
Old 12-16-2007, 12:09 AM
Registered User
 
Join Date: Oct 2005
Posts: 4,263
Before you do anything else, try disconnecting the battery and stepping on the brake pedal.
Reply With Quote
  #3  
Old 12-16-2007, 12:16 AM
Registered User
 
Join Date: Dec 2007
Posts: 31
Quote:
Originally Posted by Matt L View Post
Before you do anything else, try disconnecting the battery and stepping on the brake pedal.
Just did that...Nothing...I searched the forum earlier, Over Voltage Relay...Thoughts?
Reply With Quote
  #4  
Old 12-16-2007, 12:55 AM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
Fuse on top of OVP may have expired..................or the battery is not up to full charge [ Low voltage condition]
Charge it .
Reply With Quote
  #5  
Old 12-16-2007, 11:50 AM
waybomb's Avatar
Registered User
 
Join Date: Nov 2002
Location: St. Joe, MI; Manitowoc, WI
Posts: 1,553
Another lesson on never jump start your car.

I did it on my SL. Spent a few days clearing top codes, and found one of the OVP fuses to be blown, though it appeared fine. Use a VOM to check the fuse.

I learned my lesson.

__________________
Thank You!
Fred
2001 E430 Sport, 204,000 miles
1997 C280 Sport, 144,000 miles
1991 300SL, 189,000 miles
1987 420SEL, 149,000 miles
1986 190e 2.3 16v, 151,000
1968 W30 442, 78,000 miles
1988 46' US1 Cougar, 3 supercharged 572's
http://s4.photobucket.com/albums/y145/waybomb/
Warming the globe, 24 cylinders at a time
And I want a 126 wagon! Point me to one!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:44 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page