Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-26-2007, 04:28 PM
Registered User
 
Join Date: Jan 2004
Location: Titusville, FL
Posts: 241
Angry 500E CAN system data help

My 92 500 E has been running rough for a while. Recent (past 2 years) part replacements include actuator, upper and lower engine wiring harnesses, kickdown switch and throttle position switch. Also did tune up with cap, rotor plugs and ignition wires.

I have the following codes from checking the pins in the 38 pin connector:

Pin 4 code 17 (won't clear) Message: No CAN data transmission with EA/CC/ISC control module or CC/ISE control module
Pin 6 Code 31 (won't Clear) Message: CAN communication with LH-SFI or Left & Right control modules faulty
Pin 7 Code 3 (clears) Right EA/CC/ISC actuator (left cylinder bank M16/1)
5 (clears) Stop Lamp switch
7 (won't clear) CAN data bus signal from EA/CC/ISC, ABS/ASR, HFM-SFI or LH-SFI (right or left) control module faulty
14 (clears) Closed throttle position contact switch
Pin 8 Code 9 LH-SFI control module voltage supply, open circuit
10 Base module voltage supply output fuse F2, open circuit
11 Base module voltage supply output fuse F3, open circuit
12 Base module voltage supply output fuse F1, open circuit
13 Base module voltage supply output fuse F4, open circuit
All pin 8 codes clear
I don't get any signal from pin 19 and thought I should at least get 1 flash (no codes).

I checked all the fuses on the base module and they are good. I had recently replaced the throttle postion switch - is there a trick to installing it?

It was starting and running rough until I checked and cleared the codes (yesterday) and now it will not start (I hear the fuel pump running etc)

I desperately need guidance on this as I am planning on traveling with the car next week and need it running well. BTW, my wife is not happy with me on this car.
Thanks,
Lee

Reply With Quote
  #2  
Old 12-28-2007, 08:39 AM
Registered User
 
Join Date: Jan 2004
Location: Titusville, FL
Posts: 241
bump
Reply With Quote
  #3  
Old 12-28-2007, 08:58 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Sounds like a problem with the base module.

Base module is the power supply for the computers in the can box.

Have you looked at the distributor caps?
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #4  
Old 12-28-2007, 01:02 PM
Registered User
 
Join Date: Jan 2004
Location: Titusville, FL
Posts: 241
I repalced the plugs, caps, rotors and wires less than 2 months ago. It did not change anything. I checked the base module and it is getting power as well as all fuses.
Thanks
Reply With Quote
  #5  
Old 12-29-2007, 03:55 PM
Registered User
 
Join Date: Jan 2004
Location: Titusville, FL
Posts: 241
bump
Reply With Quote
  #6  
Old 01-07-2008, 02:41 PM
Registered User
 
Join Date: Dec 2007
Posts: 7
Angry

I have a 260E 1987 does anyone have a service manual for my car?

thanks,

Tati
Reply With Quote
  #7  
Old 01-07-2008, 04:13 PM
Registered User
 
Join Date: Sep 2004
Location: DFW / Collin County Texas
Posts: 1,882
Way to threadjack, TATI. How does your question have anything to do with the original post?

__________________
08 W251 R350
97 W210 E320
91 W124 300E
86 W126 560SEL
85 W126 380SE Silver
85 W126 380SE Cranberry
79 W123 250
78 W123 280E
75 W114 280
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:13 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page