Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-08-2008, 10:38 PM
Registered User
 
Join Date: Apr 2002
Location: Dallas Area
Posts: 397
Engine cuts out at high speed only

Car: 1986 300E

Day 1 - Driving down the highway at 60-70 mph, engine suddenly cuts out. I pull over to the side and start the car. Car starts and all is fine.

Day 2 - Same thing, drving on hwy at 60-70 mph. Engine cuts out. The engine is being driven by the transmission now - I didn't switch the trans to neutral. Without thinking, all I do is turn the ignition off and turn it back on (did not crank the starter) and the engine fires right up and no problems.

Day 3 - Same thing. But this time, I pulled over again and tried to start the car. After about four of five tries, the engine came to life and it ran like a champ.

Temperature on all three days was about 50 degrees. The stalling happened after drving about 12 miles from work out of which 7 are on the highway usually driving close to 68mph

What could be the problem? Is is fuel delivery related - vapor lock, or clogged fuel filter, or bad fuel pump/fuel pump relay.

Thanks
__________________
1986 300E (3/2002) Rear ended and totaled (10/2009)
2000 Xterra (5/2000)
1992 400E (11/2009) -Sold
1986 300E (12/2009)
2004 E500 Wagon (6/2013)
Reply With Quote
  #2  
Old 01-09-2008, 08:16 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Fuel delivery OR lack of it is a common problem.

ON the return side of the system you need to have a quart of fuel in 25-30 seconds.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 01-09-2008, 11:50 AM
Texholdem
 
Join Date: Mar 2007
Location: Dallas
Posts: 756
Quote:
Originally Posted by hs_300e View Post
Car: 1986 300E

Day 2 - Same thing, drving on hwy at 60-70 mph. Engine cuts out. The engine is being driven by the transmission now - I didn't switch the trans to neutral. Without thinking, all I do is turn the ignition off and turn it back on (did not crank the starter) and the engine fires right up and no problems.
Is it not a very dangerous thing to turn off the ignition while the car is running? the steering wheel can be blocked.
__________________
1996 E320 since 1/16/08, 171K miles as of Feb 2011

---------------------------------------------------------
1989 300CE - R.I.P. Dec 29 2007
Other MBs (sold): 1992 300E-24 - 1979 350SLC - 1984 230E - 1990 300CE
Reply With Quote
  #4  
Old 01-09-2008, 12:11 PM
ILUVMILS's Avatar
Senior Member
 
Join Date: Sep 2002
Posts: 2,557
MB steering columns don't lock until the key is removed.
Reply With Quote
  #5  
Old 01-25-2008, 09:15 PM
Registered User
 
Join Date: Apr 2002
Location: Dallas Area
Posts: 397
Any insight on where to start troubleshooting the problem will be greatly appreciated.

Would replacing the fuel filter be a good start or is the problem more serious.

Thank you,

HS
__________________
1986 300E (3/2002) Rear ended and totaled (10/2009)
2000 Xterra (5/2000)
1992 400E (11/2009) -Sold
1986 300E (12/2009)
2004 E500 Wagon (6/2013)
Reply With Quote
  #6  
Old 01-26-2008, 11:21 AM
david s poole
 
Join Date: Mar 2005
Location: dallas
Posts: 1,822
i would go straight to the distributor cap and rotor.look carefully at the centre carbon pole in cap where touches the centre of rotor.other possibility is tdc pickup at the flywheel going to ignition unit.
__________________
David S Poole
European Performance
Dallas, TX
4696880422

"Fortune favors the prepared mind"
1987 Mercedes Benz 420SEL
1988 Mercedes Benz 300TE (With new evaporator)
2000 Mercedes Benz C280
http://www.w108.org/gallery/albums/A...1159.thumb.jpg
Reply With Quote
  #7  
Old 01-26-2008, 10:25 PM
dkveuro's Avatar
Sword of Damocles
 
Join Date: Jun 2003
Location: Here an' there.
Posts: 2,548
Check the OVPR fuse and all fuses in the box...they corrode where they touch the copper fingers.

Does the Tach' drop to zero when it does this while still rolling. If so, the coil is suspect.


.
__________________
[http://languageandgrammar.com/2008/01/14/youve-got-problems-not-issues/ ]

"A liberal is someone who feels they owe a great debt to their fellow man, which debt he proposes to pay off with your money."
Reply With Quote
  #8  
Old 01-27-2008, 01:21 PM
Benzo W140
 
Join Date: Dec 2007
Posts: 22
I experienced this in the past--FUEL PUMP RELAY!. I think it was around $125 back when I had my 300E. Its located right behind the battery...
Reply With Quote
  #9  
Old 02-05-2008, 01:33 PM
Registered User
 
Join Date: Apr 2002
Location: Dallas Area
Posts: 397
Quote:
Originally Posted by Agron Bera View Post
I experienced this in the past--FUEL PUMP RELAY!. I think it was around $125 back when I had my 300E. Its located right behind the battery...
Replacing the Fuel Pump Relay fixed the problem. Thanks Agron.
__________________
1986 300E (3/2002) Rear ended and totaled (10/2009)
2000 Xterra (5/2000)
1992 400E (11/2009) -Sold
1986 300E (12/2009)
2004 E500 Wagon (6/2013)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page