Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-14-2008, 11:03 AM
Benzo W140
 
Join Date: Dec 2007
Posts: 22
Headlight "flashers" not working on 93 400SEL

The flashers don't seem to be working but the high beams do work when the headlights are on. When I pull back on the lever to flash, nothing happens. When I push forward on the turn signal lever to put on the high beams they work with no problem. I looked at the fuses and they all seam to be in good order. Anyone have this problem?

Reply With Quote
  #2  
Old 01-14-2008, 01:05 PM
Registered User
 
Join Date: Aug 2006
Location: Houston, TX
Posts: 450
you need a new combo switch. It's the one that does the turnsignals, wipers, highbeam, flash-to-pass (that's what's broke on yours), etc.

Don't remember the cost, but the R&R is fairly easy for a DIY'er - except for getting the bolt that holds the steering wheel on loose. It can be really tight.
Reply With Quote
  #3  
Old 01-14-2008, 02:58 PM
Benzo W140
 
Join Date: Dec 2007
Posts: 22
Thanks for the reply Brian,

But all of the other functions such as wipers, turn-signal and high beam work--I simply can't "flash". Thanks again, I will look around for the part and try to fix.
Reply With Quote
  #4  
Old 01-15-2008, 09:34 AM
Registered User
 
Join Date: Aug 2006
Location: Houston, TX
Posts: 450
My car had the exact same symptoms - replacing the switch solved the problem.

One thing that was an unexpected positive was the new "smoothness" to the turn signal switch. Never thought anything was wrong with the original until I installed the new switch.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 08:20 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page