Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-26-2008, 11:32 PM
Registered User
 
Join Date: May 2006
Posts: 1
Dead Clock

ALL

I seem to have a deceased clock in my '86' 190E 2.3. There doesn't seem to be any other problems. Any suggestions.

Regards

Confused

Reply With Quote
  #2  
Old 02-27-2008, 10:53 AM
david s poole
 
Join Date: Mar 2005
Location: dallas
Posts: 1,822
if you pull the cluster and take out the tach/clock and then turn it over you will see the circuitry for the clock.there are several electrolitic capacitors in it and one or two have gone bad.determine what size the capacitors are by taking unit to radio shack [replace all of them] and from there it's a simple desolder and resolder job.pay attention to the polarity[+or-] of the new parts.this has always worked for me.those are cheap parts and have about a 15yr life span.
__________________
David S Poole
European Performance
Dallas, TX
4696880422

"Fortune favors the prepared mind"
1987 Mercedes Benz 420SEL
1988 Mercedes Benz 300TE (With new evaporator)
2000 Mercedes Benz C280
http://www.w108.org/gallery/albums/A...1159.thumb.jpg
Reply With Quote
  #3  
Old 02-27-2008, 11:10 AM
Dee8go's Avatar
Senor User
 
Join Date: Apr 2006
Location: The People's Republic of Arlington, VA
Posts: 7,193
How hard is it to take the cluster out? Mine is broken, too.
__________________
" We have nothing to fear but the main stream media itself . . . ."- Adapted from Franklin D Roosevelt for the 21st century

OBK #55

1998 Lincoln Continental - Sold
Max 1984 300TD 285,000 miles - Sold
The Dee8gonator 1987 560SEC 196,000 miles - Sold
Orgasmatron - 2006 CLS500 90,000 miles
2002 C320 Wagon 122,000 miles
2016 AMG GTS 12,000 miles
Reply With Quote
  #4  
Old 02-27-2008, 11:46 AM
david s poole
 
Join Date: Mar 2005
Location: dallas
Posts: 1,822
the biggest prob on 190 is the short speedo cable.disconnect cable from trans so as to feed more of it towards the front,then you can pull the cluster far enough forward to disconnect the cable and all the plugs.

__________________
David S Poole
European Performance
Dallas, TX
4696880422

"Fortune favors the prepared mind"
1987 Mercedes Benz 420SEL
1988 Mercedes Benz 300TE (With new evaporator)
2000 Mercedes Benz C280
http://www.w108.org/gallery/albums/A...1159.thumb.jpg
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page