Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-01-2001, 11:04 PM
Posts: n/a
Angry '84 300D turn signals/hazard no blink!

I'm down to the last nagging annoyances, one of which is the turn signals/hazards not "blinking". All fuses/bulbs are good; in fact sometimes the signals actually blink.
Am I to replace the "impulse relay"? (that's what came up on the parts search for "hazard relay"). Is it easy to get to?
Reply With Quote
Old 08-01-2001, 11:44 PM
Senior Member
Join Date: Apr 2001
Location: Beech Island, S.C.
Posts: 468
Probably need to replace the hazard switch.
Reply With Quote
Old 08-02-2001, 12:56 AM
MikeTangas's Avatar
Senior Member
Join Date: Apr 2000
Location: So. Cal
Posts: 4,430
Try cycling the hazard switch on/off a few times. Often it is simply not seated properly, when that happens the turn indicators and hazard lights no workee. A very cheap test too.
Mike Tangas
'73 280SEL 4.5 (9/72)- RIP
Only 8,173 units built from 5/71 thru 11/72

'02 CLK320 Cabriolet - wifey's mid-life crisis

2012 VW Jetta Sportwagon least its a diesel

Non illegitemae carborundum.
Reply With Quote
Old 08-02-2001, 07:21 AM
Posts: n/a
These switches gather dirt and such inside them and give trouble frequently. They are well made, and I have, more than once, taken them apart, cleaned them and put them back together with good results. Worst case you buy one for $20 or something like that.

Good luck,
Reply With Quote
Old 08-14-2001, 10:50 PM
Posts: n/a
it's the relay

The switches had nothing to do with the problem. The relay does not always open/close the circuit. However, I'm extremely frugal, and will likely try disassembling the unit and cleaning it before buying a new one.
Reply With Quote
Old 08-16-2001, 12:35 AM
Registered User
Join Date: Jun 1999
Location: Los Angeles, Calif, USA
Posts: 521
If you have an easy way to test the switch, please let me know. I always do what Larry is doing, cleaning the switch, because it is facing up and dirt easily get inside. I saw one case that the switch was overheated and the plastic around one of the terminals melt away.

The relay is expensive and it has electronics inside. It looks hard to clean.

Reply With Quote
Old 08-16-2001, 02:54 AM
Registered User
Join Date: Jul 2001
Posts: 74
My car has a similar problem. My hazardstdo not light, blink or do anything. My turn signals only blink if I hold the stalk in the right position, they do not light up at all unless the stalk is held in exactly the right position.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
clack,clack sound in lft rear wheel on rt turn GEORGEPECKY Tech Help 1 08-24-2004 02:43 PM
190e turn signals not working properly AMG Tech Help 5 12-01-2003 09:21 PM
turn signal problem after steering box R&R rvolheim Tech Help 3 06-07-2003 04:19 PM
Hot Start Problem -- 220 Will Not Turn over when Hot MBenz2 Tech Help 0 03-10-2003 06:29 PM
300D turn signal lever won't go back to neutral poptest Tech Help 2 01-08-2000 05:45 AM

All times are GMT -4. The time now is 07:24 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page