Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-02-2008, 04:11 AM
thevtechater's Avatar
indomercedes
 
Join Date: Jan 2008
Location: West Java
Posts: 40
w202 injector problems

my c180 have been having start up problems when it's warm. see, i have to crank it more than once to get the engine running if the engine is warm. if the engine is cold, it will run with a single try on the ignition but followed by a few seconds of gargling sound fromthe exhaust. my mechanic told me that it might be the injector got dirty. so i have him take the injectors out and when he checked it it's true that two out four injectors are not atomizing the fuel correctly , so i have them cleaned by running injector cleaner thru them while intermittently supplying electricity from a battery. after a few squirts the injectors atomized correctly. after doing this process the car would run well for like a month or so but then the problem comes back. fuel efficiency would start to drop accompanied by ignition hesitation. can u help me out? thanks

Reply With Quote
  #2  
Old 04-02-2008, 08:01 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Sounds like you are getting very low quality fuel, have you tried an additive in the fuel tank?
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 04-02-2008, 11:48 PM
thevtechater's Avatar
indomercedes
 
Join Date: Jan 2008
Location: West Java
Posts: 40
yep low quality

i guess, the quality of the fuel here in a third world country is so pure. sometimes the fuel even contains water in it. thats why my tank level sensor is always broken. what kind of additive u would suggest for my condition. or should i just clean the injectors evey month or so?
Reply With Quote
  #4  
Old 04-02-2008, 11:50 PM
thevtechater's Avatar
indomercedes
 
Join Date: Jan 2008
Location: West Java
Posts: 40
correction

i meant the fuel quality is so poor not pure . havent had lunch yet so my brain gets dumb

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:48 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page