Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-13-2001, 10:54 AM
Registered User
Join Date: May 1999
Location: Diamond Bar, CA
Posts: 73
Unhappy Help! 94 C280 lost power steering, and ABS and battery lights on...


On my way to work this morning, my C280 suddenly lost power steering while driving into the company parking lot. The ABS and battery lights are also on from the console. Fortunately all these happened near where I work, so I can sit here writing this message. Now my problem is that I have to find a quick fix before I go home. Any body has any idea about what's happening to my car? Thanks.
Harry (94 C280)
Reply With Quote
Old 08-13-2001, 11:27 AM
Join Date: Jul 2001
Location: Old Lyme, Connecticut
Posts: 3,596
Have you looked under the hood and checked the serpentine belt that drives the auxiliaries? Sounds like this item failed and you need a new one. This belt drives the power steering and the alternator. Jim
1986 Euro 190E 2.3-16 (291,000 miles),
1998 E300D TurboDiesel, 231,000 miles -purchased with 45,000,
1988 300E 5-speed 252,000 miles,
1983 240D 4-speed, purchased w/136,000, now with 222,000 miles.
2009 ML320CDI Bluetec, 89,000 miles

1971 220D (250,000 miles plus, sold to father-in-law),
1975 240D (245,000 miles - died of body rot),
1991 350SD (176,560 miles, weakest Benz I have owned),
1999 C230 Sport (45,400 miles),
1982 240D (321,000 miles, put to sleep)
Reply With Quote
Old 08-13-2001, 11:44 AM
Registered User
Join Date: May 1999
Location: Diamond Bar, CA
Posts: 73

Just went check under the hood. You are right, the serpentine belt is gone. Thanks.
Harry (94 C280)
Reply With Quote
Old 08-13-2001, 05:23 PM
David C Klasse's Avatar
CheFrac is Back!
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352
Interesting... let us know how the repair goes! Glad it's nothing major!!
2006 E350 w/ 155k miles (Daily Driver)

1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote
Old 08-14-2001, 02:16 PM
Registered User
Join Date: May 1999
Location: Diamond Bar, CA
Posts: 73
Just got the car back from an independent shop. After a night in the shop and $119, the C280 is on the road again. The car is a 94 with about 64K miles on the clock. I worried if it's an accessory stocked that caused the belt to break however it's not the case. The charge breaks down into $80 labor and $36 belt plus tax if that matters. Thanks.
Harry (94 C280)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
ASR + ABS lights + no cruise = ??? 400E Tech Help 4 03-30-2002 08:31 AM

All times are GMT -4. The time now is 06:48 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page