Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-08-2008, 11:08 AM
TAG's Avatar
TAG TAG is offline
1987 300E
 
Join Date: May 2008
Location: Central NJ
Posts: 60
No Tach, No A/C, CC jumpy = OVP?

First a tip of the hat to everyone here. I've only recently acquired an '87 300E w/155k and the info here has enabled me to fix the windows, power steering pump and few other odds and ends.
The latest problem to tackle is summarized above: no tach, no a/c and the CC jumps from the set speed up and back again repeatedly. I'm not sure if these all point to the OVP or if they are independent of each other.
I've also disconnected the coolant level sensor to turn the light off on the dash if that is of any consequence.
I searched the posts here and it seems as though it may be the OVP but I'm not sure.


Last edited by TAG; 05-08-2008 at 12:30 PM.
Reply With Quote
  #2  
Old 05-08-2008, 02:12 PM
Mistress's Avatar
No crying in baseball
 
Join Date: Apr 2006
Location: Inside a vortex
Posts: 624
Re-attach the coolant level sensor, if there is enough coolant in there and the light stays on you might need to replace the thermostat.
__________________
"It's normal for these things to empty your wallet and break your heart in the process."
2003 S430- "Yolanda"
Reply With Quote
  #3  
Old 05-08-2008, 02:33 PM
TAG's Avatar
TAG TAG is offline
1987 300E
 
Join Date: May 2008
Location: Central NJ
Posts: 60
Ok...but is that related? And why wouldn't that indicated a bad sensor?
Reply With Quote
  #4  
Old 05-08-2008, 03:48 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
Try giving fuse #7 a spin...
__________________
A Dalton
Reply With Quote
  #5  
Old 05-08-2008, 04:07 PM
TAG's Avatar
TAG TAG is offline
1987 300E
 
Join Date: May 2008
Location: Central NJ
Posts: 60
Cleaned of fuse #7. No go. Still interested in the thermostat theory.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page