Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-17-2001, 11:31 AM
Posts: n/a
correct running rpms for 190E

what are the correct running rpm's for 190E? Mine (85, 2.3, 119K) has the following:

idle in park: 1300
idle in drive: 900
at 45 mph 2000
at 55 mph 2500
at 65mph 3000
at 75mph 3500

are these normal? Also, I read somewhere that the rpm drop when shifting from park to drive should not be more than 50 - mine (the drop) is 400! With the A/C on in drive, it goes down another 150 (to 750). could this signify a problem?

Reply With Quote
Old 08-17-2001, 04:43 PM
David C Klasse's Avatar
CheFrac is Back!
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352
Your RPMs when the car is at speed sound perfectly normal (all in 4th gear). Though your idle seems off. This could be caused by a few different factors. If you do a search I'm sure you'll find the possible causes. Good luck!
2006 E350 w/ 155k miles (Daily Driver)

1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote
Old 08-20-2001, 01:24 PM
Posts: n/a
Thanks for your reply David. I did a search and have a couple more questions.

My car also has the following symptoms - hesitation/rough idle on cold engine (none on hot), occasional cold start problem (needs a long 2-3 sec crank). Secondary ignition components are all new. OVP relay is new. New injectors.

Could it be the air flow sensor, and/or the fuel pump relay? How do I check whether these two are working properly - what is the testing procedure?

Reply With Quote
Old 08-21-2001, 02:49 PM
Posts: n/a
Also, the hesitation/rough idle on cold engine is less is the engine is made rich.

So how should one check and test the airflow sensor and the fuel pump relay?

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
1998 C280 Temperature running higher. Ionman Tech Help 12 04-05-2011 01:02 PM
190e running rich with eha on/off.Bad mpg.Help! azhari Tech Help 85 07-15-2007 07:37 PM
Running Hotter Than Normal chrisalex78 Diesel Discussion 19 11-04-2003 10:26 PM
99 ML320 running board lighting module 16ue ML, GL, G-Wagen, R-Class, Unimog, Sprinter 1 05-06-2003 10:13 PM
Grandad's 124 running really hot; solved! azhari Tech Help 0 02-01-2003 04:10 AM

All times are GMT -4. The time now is 08:34 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page