Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-20-2001, 04:39 PM
jfujimoto
Guest
 
Posts: n/a
'85 190E rough gear engagement

Hi all,

Sometimes my "baby" has severe shifting problems out of PARK and NEUTRAL. There is a 1.5 second duration of severe vibrations. Seems like the transmission is having a problem engaging into gear. The car has 51K miles. Any ideas of what to check/fix?

Thanks,

Jeff
Reply With Quote
  #2  
Old 08-21-2001, 12:38 AM
MB TECH
Guest
 
Posts: n/a
I would service the trans, drain the converter(part of the service)
check the old filter for the paper sucking up into the valve body.
If the trans still acts up you might replace the B2 piston in the trans.
Hope this helps
Reply With Quote
  #3  
Old 08-21-2001, 02:03 AM
Registered User
 
Join Date: Nov 2000
Location: Ontario, Canada
Posts: 463
how much is a B2 piston replacement?

Does the dealer drain the converter during a transmission fluid change or would you have to specify that???

Mike McKinney
__________________
190E 2.6 - 244 000 km
Reply With Quote
  #4  
Old 08-21-2001, 04:24 PM
jfujimoto
Guest
 
Posts: n/a
MBTECH,

Thanks for the clue on my tranny problem. I'll check the filter and research the B2 piston on my repair CD.

Jeff
Reply With Quote
  #5  
Old 08-22-2001, 04:07 PM
jfujimoto
Guest
 
Posts: n/a
I serviced the transmission last night and found a smidgen of white goop at the bottom of the oil pan near the drain plug.

The "bucking bronco" syndrome, also called "clunking" only happens when I shift into reverse. All other shifting is MB perfect. I searched the forum to find that the flex disc could be the culprit. Correct? Anyone replace their flex disc recently? Easy job?

Thanks,

Jeff
Reply With Quote
  #6  
Old 08-22-2001, 06:23 PM
MB TECH
Guest
 
Posts: n/a
Flex disc seem to be a weak link as far as I'm concerned on the 201 and 124 bodies. Especially the early ones. I would make sure the modulator pressure is not cranked up to high either and the control cable is free and not binding.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
rough idle in drive 190E billwach Tech Help 11 12-16-2002 04:54 PM
85' 190e runs rough when cold osheill Tech Help 2 05-07-2002 12:33 PM
m103 190e 2.6 rough idle, oil loss plato Tech Help 2 03-17-2001 01:14 AM
rough idling 190e Rawny12017 Tech Help 1 12-22-2000 09:33 PM
Rough warmup during cold engine - 190E 2.3 agupta Tech Help 3 11-02-2000 03:32 PM



All times are GMT -4. The time now is 12:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page