Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-24-2001, 10:36 PM
Posts: n/a
Failed wiring harness--W124 400E

Greetings all, I apologize if this topic has come up recently and I was unable to find it. My 92k mile 1992 400E suffers from a faulty wiring harness between the computer and engine. The insulation around each wire is seperating, leaving bare wires to touch, which seems to be a problem with 124 V8 cars. It has been told to me that MB has been known to replace this known faulty harness at low or no cost, but I am experiencing some difficulty in getting a straight answer from my closest dealer. I would appreciate replies from those who know what MB's role in the harness' replacement will be. The service "advisor" at Atlanta Classic Cars only gives cryptic answers.

Thank you for any insight.
Reply With Quote
Old 08-25-2001, 07:56 AM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
As your car is 9 years old I would doubt that they would replace the harness unless you bought the car new & it had 100,000 miles or less.
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
Old 08-27-2001, 06:22 PM
Posts: n/a
Thanks for the replies and link. I am _not_ the original owner, but it is a very well maintained car (with records) under 100k miles. MB is yet to give me a definitive answer.

Reply With Quote
Old 09-03-2001, 09:53 AM
Registered User
Join Date: Mar 2000
Location: Stockholm, Sweden
Posts: 44
Mercedes have done some Safety Recalls for a lot of cars, at least if you read the information given by Alldata at:

A snip from that page:
95-0223........MAR 95......Wiring Harness Chafing/Shorting
95V031000......FEB 95......Wire Harness Protecter Installation

Good Luck!
/Patrik S.
Patrik Sjoblom....1993 MB 320 CE......Bought Jan 2001. Only 16.8 mpg
Stockholm.........Silvermetallic....DEFA immobilizer/alarm + Original larm
SWEDEN............17x7.5 ET35 wheels with 215/45-17 Kumho 712 ECSTA .
Reply With Quote
Old 09-04-2001, 10:56 AM
Registered User
Join Date: Aug 2001
Location: Florida
Posts: 270

The local dealer replaced min on a 92 400E with 81000 k on it without a problem.

Good luck.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Wiring harness connector removal--Help! Dirtywhitebenz Tech Help 6 04-16-2004 11:43 AM
'93 300SE Wiring Harness mpayne Tech Help 1 06-12-2003 08:23 AM
I need wiring diagram for 96 SL500 stereo harness. spinedoc SL Forum 6 05-17-2003 12:50 PM
400E Engine Wiring Harness Pbalias Tech Help 1 12-27-2000 12:59 PM
400e Wiring Harness PLEASE HELP!!!! dsantos Tech Help 4 10-17-2000 11:47 PM

All times are GMT -4. The time now is 01:11 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page