Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-26-2008, 09:11 AM
Registered User
 
Join Date: Aug 2001
Location: Florida
Posts: 272
C280 A\C Auxilliary fans Controller issue

Good morning. Yesterday when I was trying to pull codes from the dash controller on the C280 I might have disabled the electric fan circuit. When I depressed the REST and Ec switch the controller went into Diagnostic mode. However when I depressed the EC button again the controller went into a different mode only on the left side of the display and that broke down further into three different subsections that recognized values in dashes , blanks or 1's which could be changed using different buttons on the controller. . I did not intentionally change any settings here but I may have. The electric fans have not come on since. Is there a reset protocol for the controller.
Thanks.
Brian
1998 C280
1996 S320
1992 400E
all still in the stable

Last edited by Bzoo; 06-26-2008 at 06:27 PM.
Reply With Quote
  #2  
Old 06-27-2008, 06:32 PM
Registered User
 
Join Date: Aug 2001
Location: Florida
Posts: 272
Picked up the evap sensor today...don't think the fans are related to it but we shall see...installing first thing in the morning. I will post the results.

Brian
Reply With Quote
  #3  
Old 06-30-2008, 06:18 PM
Registered User
 
Join Date: Aug 2001
Location: Florida
Posts: 272
Replaced the evaporator sensor. The fans are working correctly as well as the a/c. I can't find the correlation but when it comes to a/c in Florida i never look a gift horse in the mouth.
Reply With Quote
  #4  
Old 07-05-2008, 03:54 PM
Diesel mechanic illinios
 
Join Date: Nov 2007
Location: illinios
Posts: 5
The cooling fans are activated when the AC is switched on. This is to keep cool air moving past the core in front of the radiator. The freon in the system gets very hot, and if it didnt have a way to lose heat, the ac wouldnt be very comfy:-)
__________________
88 560sec (might be parting or selling)
94 S320
94 S600 nicknamed "moneypit"
Reply With Quote
  #5  
Old 07-05-2008, 06:28 PM
Registered User
 
Join Date: Aug 2001
Location: Florida
Posts: 272
Thank you very much for your help. I guess that means when the comp wasn't kicking on then the freon wasn't getting hot so then...no fans. Thanks for helping me understand the system.

Brian
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:19 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page