Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-26-2008, 09:31 PM
Registered User
 
Join Date: Aug 2001
Location: Ohio
Posts: 183
Any Experiences MT2500 and 96 C280 HFM?

Hi have Snap-On MT2500 scanner with MB1 cable and S-20 key, 2003 Mercedes cartridge connecting to 38 pin under hood connector on 96 C280.

Having great problems connecting to HFM module (no communication error). Can easily connect to the diagnostic module (DM).

The DM is only used on US cars. Is this the only module that the MT2500 will properly be able to talk with on this US car.

Any tricks or techniques that I am missing getting the MT2500 to talk to HFM ecu.?

Any help is most welcome and appreciated.

Thanks

__________________
Martineau Gauda
mgauda@sprintmail.com

96 C280 Mercedes
82 Rolls Royce Silver Spur
Reply With Quote
  #2  
Old 06-27-2008, 08:13 PM
Registered User
 
Join Date: Aug 2001
Location: Ohio
Posts: 183
Update:

The S-34 and S-33 keys arrived from snap-on and I was able to communicate pproperly with the airbag system and with the automatic temp system using the same 38 pin connector.

Now I can communicate with the DM, Airbag, and Climate control. Still no go with the HFM or the transmission systems.

Thanks
__________________
Martineau Gauda
mgauda@sprintmail.com

96 C280 Mercedes
82 Rolls Royce Silver Spur
Reply With Quote
  #3  
Old 06-28-2008, 01:04 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
Are you placing your probe in the right diagnostic hole? Do you have a 722.6 trans? A 96 could have either 722.3/4 or 722.6, only the 722.6 will talk.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #4  
Old 06-28-2008, 02:04 PM
Registered User
 
Join Date: Aug 2001
Location: Ohio
Posts: 183
Steve, the transmission may be 722.4 so your confirmation that it should not talk to trans is very helpful.

The connector I am using is the MB-1 which is a 38pin cable connector cable that interfaces with the 38pin under hood connector. HFM should be on pin 4 of the 38 pin underhood connector. I back probed pin 4 on the 38 pin Diag connector with the scanner connected with Fluke 88V and there is signal burst indication when the MT2500 attempts communicating. But it always returns "No communication" error, KOEO or KOER.

The model is before 8/96 so this should be HFM. It was my understanding that ME was introduced after that date.

Should the HFM be talking to the MT2500 if there is a DM? Are there common faults that are associated with no comm with the HFM?

Steve your experienced assistance is much appreciated.


Thanks
__________________
Martineau Gauda
mgauda@sprintmail.com

96 C280 Mercedes
82 Rolls Royce Silver Spur
Reply With Quote
  #5  
Old 06-29-2008, 11:00 AM
Registered User
 
Join Date: Aug 2001
Location: Milford, DE
Posts: 1,485
Quote:
Originally Posted by Martineau Gauda View Post
Are there common faults that are associated with no comm with the HFM?
My MT-2500 does has the "no communication" problem with certain cars and sub-systems, It seems like Snap-on did the best they could in figuring out how to talk to MB proprietary systems but it doesn't seem to work 100% of the time for all systems.

I'm just glad that it works for some of the systems....
__________________
98 Dodge-Cummins pickup (123k)
13 GLK250 (125)
06 E320CDI (310k)
16 C300 (62K)
Reply With Quote
  #6  
Old 06-30-2008, 04:55 PM
Registered User
 
Join Date: Aug 2001
Location: Ohio
Posts: 183
Thanks Tim,

Before I give up attempting to connect with HFM are there any other known faults with the C280 that may interfere with the communication with HFM ecu. Would there be anything else that would be a prerequisite when attempting to communicate on this vehicle other then setting HFM and turning on the ignition.

Just want to make sure I am not missing anything simple.

Thanks
__________________
Martineau Gauda
mgauda@sprintmail.com

96 C280 Mercedes
82 Rolls Royce Silver Spur
Reply With Quote
  #7  
Old 06-30-2008, 08:21 PM
Registered User
 
Join Date: Aug 2001
Location: Milford, DE
Posts: 1,485
Quote:
Originally Posted by Martineau Gauda View Post
Thanks Tim,

Before I give up attempting to connect with HFM are there any other known faults with the C280 that may interfere with the communication with HFM ecu. Would there be anything else that would be a prerequisite when attempting to communicate on this vehicle other then setting HFM and turning on the ignition.

Just want to make sure I am not missing anything simple.

Thanks
Martineau

I don't have a clue about a C280, I've been able to connect to HFM systems on M119 and the M104 engine in the W124 and W210 chassis but I've never attempted to connect to HFM on that specific car/engine combo. I've mainly had problems connecting to the EA/ISC/CC modules and sometimes to the airbag systems.

Sorry I can't be of any more help.
__________________
98 Dodge-Cummins pickup (123k)
13 GLK250 (125)
06 E320CDI (310k)
16 C300 (62K)
Reply With Quote
  #8  
Old 07-03-2008, 08:10 AM
Registered User
 
Join Date: Aug 2001
Location: Ohio
Posts: 183
Another Update:

Steve and Tim

Received the S-21 Key from Snap-on and the Mt2500 can talk with the EA/ISC/CC unit properly using the MB-1, 2003 cartridge and MB-1 cable using the 38 pin under hood connector.

Communication with the Airbag systems, Climate control, Diagnostic Module, and EA/ISC/CC modules are completely proper.

Still cannot talk to the HFM/DFI system (No Communication Error). Indeed perplexing, as it is my understanding that the MT2500 should easily communicate with the HFM using the 38pin connector, S-20key, MB-1 cable and 2003 cartridge.

Still hoping that someone out there has seen this specific problem with the HFM and MT2500.

Thanks

__________________
Martineau Gauda
mgauda@sprintmail.com

96 C280 Mercedes
82 Rolls Royce Silver Spur
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:18 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page