Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-27-2001, 12:04 PM
Registered User
 
Join Date: Feb 2001
Location: Colleyville, TX
Posts: 229
92 190E 2.6 - Strange noise

Hi,
Lately there is a strange noise coming from belt area of the engine. It sounds like a scraping noise but can't tell where it is coming from. I thought the pulley or belt was scraping/rubbing against some piece of debris or metal but I couldn't find anything. Initially it sounded like it was coming from the water pump area but when I got close to the water pump it appears to come from the compressor/exhaust manifold area. The sound is not continuous and but happens at random intervals. It happens at idle and when the car is in motion. Please share ideas. Thanks
smk_texas
92 190e 2.6 99K
86 BMW 325E - 140K
Reply With Quote
  #2  
Old 08-27-2001, 12:13 PM
pmizell's Avatar
Benz Zealot
 
Join Date: Jun 2001
Location: Houston, Texas
Posts: 838
If you haven't done so, check to see if your distributor cover has shaken loose and is rubbing against the fan clutch. The two are very close together.

Good luck

~Paul
Reply With Quote
  #3  
Old 08-27-2001, 07:13 PM
Registered User
 
Join Date: Feb 2001
Location: Colleyville, TX
Posts: 229
I will check it and let you know. Thanks
smk_texas
Reply With Quote
  #4  
Old 08-27-2001, 08:07 PM
Registered User
 
Join Date: Apr 2000
Location: LEMONT-CHICAGO
Posts: 412
Thats what my water pump sounded like before it began to leak. Keep an eye on your coolant level and think about whether or not that you want to do this job. By the way, mine made the noise off and on randomly and then I noticed coolant leakage that progressively got worse.
__________________
1990 190E 2.6
1996 Grand Voyager 3.3
1985 Mustang GT 5.0 5 SPD
1982 Suzuki GS 750T
Reply With Quote
  #5  
Old 08-30-2001, 11:25 AM
Registered User
 
Join Date: Feb 2001
Location: Colleyville, TX
Posts: 229
Yesterday I put a stethoscope on the waterpump but I couldn't tell if anything was wrong. The scraping noice appears to come from just below the exhaust manifold. There was no coolant loss or leak at the waterpump. There appears to be no play in the coolant pump pulley either. I am confused now. Help !! Thanks
smk_texas
92 190E 2.6 99K
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
190E 2.6 into 190E 3.2-24V...... RolexBenz190E Performance Paddock 32 12-16-2003 08:06 PM
190E tapping noise resolved! ScottyC190E Tech Help 9 04-01-2003 03:40 AM
92- 190E 2.6 Overheated Yesterday smk_texas Tech Help 7 08-16-2001 10:50 AM
MosselMan Turbo for 190E 2.6? Throttle Performance Paddock 9 01-26-2001 01:08 AM
Complete Make-Over for 93 190E 2.6 Chiragp Detailing and Interior 3 04-25-2000 11:21 PM



All times are GMT -4. The time now is 01:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page