Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-27-2001, 11:54 PM
420benz's Avatar
Registered User
 
Join Date: Jul 2001
Posts: 961
a/c problem

Cannot redirect airflow from defrost mode. About half blows on windshield and half out of dash vents.On the 420 sel the correct button to push is dark arrow down outline arrow up. Is there a flap stuck or a vacuam hose leaking , if so where should i look?

Last edited by 420benz; 08-28-2001 at 12:01 AM.
Reply With Quote
  #2  
Old 08-28-2001, 01:53 AM
HaYN Benz
Guest
 
Posts: n/a
Hey 420,

Do a search under "diaphram". You will see a thread started by 1994C220 that has the info you need. You might want to look at the other threads as well.

Good luck.:p
Reply With Quote
  #3  
Old 08-29-2001, 12:20 AM
420benz's Avatar
Registered User
 
Join Date: Jul 2001
Posts: 961
Cannot find thread[ DIAPHRAM]. Must be doing somthing wrong,HELP.
Reply With Quote
  #4  
Old 08-29-2001, 01:55 AM
Senior Member
 
Join Date: Apr 1999
Location: Walnut,CA,USA
Posts: 554
You have vacuum leaks in your air condition vacuum system you can start checking from vacuum switching over valve unit locate behind right side of the radio with a vacuum hand pump let me know what color line is leaking I'll tell you witch parts you need.
__________________
MB STARS Master Guild Technician,17 years MB tech
14 years independent shop owner
Reply With Quote
  #5  
Old 08-29-2001, 03:11 AM
HaYN Benz
Guest
 
Posts: n/a
OK,

Try going here:

Minor problems but annoying(A/C, sunroof, passenger window)

If this link doesn't work, I found it by clicking on the SEARCH tab above, then typing in the word DIAPHRAM (no quotes), and clicking on the PERFORM SEARCH button.

Hope that helps. Again look for the thread started by 1994C220.
Reply With Quote
  #6  
Old 08-29-2001, 10:39 PM
420benz's Avatar
Registered User
 
Join Date: Jul 2001
Posts: 961
Thanks HAYN BENZ i found it. Also thanks mb stars i will try to find the leak tomorrow. I will let you know.
Reply With Quote
  #7  
Old 08-30-2001, 07:33 PM
420benz's Avatar
Registered User
 
Join Date: Jul 2001
Posts: 961
HaYN BENZ:I REMOVED THE DECRITIVE TRAY FROM UNDER THE PASS. AIR BAG AND COULD NOT FIND ANY VAC. LINES,CONTROLS OR ANYTHING ELSE. AT FIRST I COULD NOT GET ANY HEAT BUT NOW HEAT ONLY COMES OUT IN DEFROST MODE,LESS FROM DASH. APROX.75% OF AIR COMES FROM DEF. AND 25% FROM DASH. A/C IS THE SAME.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
A/C problem Joko Tech Help 5 08-12-2003 01:44 PM
Swapped the CCU, the problem came back - new theory, still need help with a/c diagnos bodyart27 Diesel Discussion 1 06-29-2003 05:34 PM
a/c problem became less strange jivadent Diesel Discussion 2 10-30-2002 05:19 PM
Strange a/c problem on '86 300E can-do Tech Help 4 06-07-2002 01:12 AM
A/C problem has got me hot!!! Matt201 Tech Help 1 08-01-2001 12:39 AM



All times are GMT -4. The time now is 11:19 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page