Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-30-2001, 05:50 PM
2phast's Avatar
Registered User
Join Date: Jul 2001
Posts: 613
1992 190E surging while driving...Help!

My 1992 190E 2.6 just recently starting surging while driving. This seems to happen when the car is hot, not when its cold. It also happens when on the freeway or in town. Also, there appears to be loss of power when accelerating from a stop. I have already replaced the spark plugs and fuel filter. The plug wires are good.

Based on other cars I have had, I would guess the O2 sensor, but I really don't want to start throwing parts at a problem (especially when the O2 sensor for the Benz is $$$$)

Any one experience a similar problem and have a fix?

Reply With Quote
Old 08-30-2001, 08:15 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
I would check the fuel pressure next! It sounds like one of the pumps could have failed.
Donnie Drummonds
Reply With Quote
Old 08-31-2001, 04:27 AM
2phast's Avatar
Registered User
Join Date: Jul 2001
Posts: 613
If one of the pumps have failed, wouldn't the problem be there whether or not the engine is hot or cold? Problem seems to materialize when the engine has heated up, no surging when its cold, although when I do start the car it is a bit rough, requiring me to give it a bit of gas.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Reasonable Price for a 93 190E 2.6 w/ 90K miles Chiragp Mercedes Used Parts For Sale & Wanted 8 01-28-2005 09:45 PM
FS: 1992 190e 2.6--- ATL area caseylovesmoney Mercedes Cars For Sale 0 06-09-2004 07:59 PM
1992 190e sunroof problems... Urquattro Tech Help 0 03-06-2004 08:48 PM
1992 190E 2.6 Radio problem RHEG Car Audio and Multimedia 1 02-23-2004 05:21 PM
Reasonable Price for a 93 190E 2.6 w/ 90K miles Chiragp Performance Paddock 3 04-22-2000 11:11 PM

All times are GMT -4. The time now is 12:24 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page