Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-04-2008, 03:05 AM
Registered User
 
Join Date: Nov 2002
Location: Los Osos, CA
Posts: 211
Strange climate control unit problem...

Hi guys,
In the midst of trying to get my AC to work in the 300e, I've stumbled on an odd problem. I can't get the climate control panel to send a turn on signal to the Klima relay and on to the compressor. I've tested the relay, when battery voltage is applied to it, it kicks on the compressor, blows nice and cold. I've tested the temp sensors that input to the climate control panel, all appear good per MB's specs. And I've thus far put in three different, albeit used climate control panels, all work fine in all different functions, but none will send a voltage signal to the Klima relay. I'm completely stumped, any ideas?

Thanks!
Scott
__________________
Scott

1987 300e - The 200,000 mile TurboTechnics rocketship.
Reply With Quote
  #2  
Old 08-04-2008, 09:32 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
The a/c controller sends a ground signal to pin #10 of the Klima relay.

ON a 1987 car the most likely problem is the exap temp sensor.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:40 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page