Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-25-2008, 01:46 PM
Registered User
 
Join Date: Aug 2008
Posts: 19
mas, lean? Please help

I have a 1996 e320, the car has an idle surge problem and when running it seems to me it has a lean smell comming from the exhaust. I say lean because I have an 87 Monte SS that has to run rich and the smells are not at all alike. I cleaned the MAS with the crc cleaner to see if that would stop the surging idle but no go. The smell almost smells like some sort of chemical cleaner. Am I crazy? Also when I bring the rpm's up the car will run for a minute or 2 then stall. Any Ideas? Please help this is driving me crazy.
Karl

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page