Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-08-2008, 11:58 AM
Registered User
 
Join Date: Jul 2008
Posts: 12
no aux fans, '99 500sl

Last week the AC on our '99 500sl stopped working when the car was at low speed and at idle. No codes on the AC system. With help from a MB list, narrowed it down to the aux fans not coming on as the probable cause. Can anyone help troubleshooting why they won't work? The aux fan fuse is good. I assume there is a pressure or temp switch that is not working, a broken wire, and I've read about a rheostat on some MBs, but don't know what to look for or where in the engine bay. Any help is appreciated.
Pete
Reply With Quote
  #2  
Old 09-08-2008, 12:56 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
You have either an incorrect year or model ....

'99 is a SL500
500SL is '93 and before ..

They have different aux fan circuits..
__________________
A Dalton

Last edited by Arthur Dalton; 09-08-2008 at 01:31 PM.
Reply With Quote
  #3  
Old 09-08-2008, 04:31 PM
Registered User
 
Join Date: Aug 2006
Posts: 141
a/c 500SL

Check the fuse for the aux. fan.
Make sure fan(s) isn't stuck,If it is replace.Test by applying power to fan motor.
Check operation of aux. fan relay. Jump pressure switch wires (pigtail)on rec./drier. Listen for click at relay. look for power at fan wires.
Mike
Reply With Quote
  #4  
Old 09-08-2008, 04:35 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
That would be correct if he has a 500SL..not if he has a SL500...
__________________
A Dalton
Reply With Quote
  #5  
Old 09-08-2008, 06:03 PM
Registered User
 
Join Date: Jul 2008
Posts: 12
thanks for the quick responses,
my bad, it is a '99 sl500 - typing faster than thinking. Where exactly are the fan relay and pressure switch located? The fuse is okay, both fans spin freely. Hard to find a good place to put power to the fans
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:53 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page