Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-17-2008, 01:31 PM
Registered User
 
Join Date: Aug 2008
Posts: 19
96 e320

96 e320
I have a 96 e320 that has been driving me nuts. When I go to start it, it starts and the idle surges a few times before smoothing out, then when I give it some gas it stalls as it approches 2k rpm. Then when I go to restart sometimes it starts sometimes it starts and stalls right out, any ideas???? It will stumble like its out of gas, but I know that not to be the case.
Karl

Reply With Quote
  #2  
Old 09-17-2008, 02:32 PM
Registered User
 
Join Date: Aug 2003
Location: Phoenix
Posts: 3,726
Should be throwing a fault code(s).
Reply With Quote
  #3  
Old 09-17-2008, 04:51 PM
Registered User
 
Join Date: Aug 2008
Posts: 19
We changed the battery and alt. and I think that might have reset whatever codes were in there. My problem is I'm afraid to drive it because I don't want to get stuck. I think the codes reset after about 40 miles.
Karl
Reply With Quote
  #4  
Old 09-17-2008, 04:54 PM
Registered User
 
Join Date: Aug 2008
Posts: 19
It's my daughter in laws car, and the light was on. My son said it was an egr code but I didn't see it for myself. I pulled the egr valve and put a vacuum check on it and it held, I then cleaned it real good with the valve open and closed and it looked as if it was opening and closing smoothly. Any other ideas? I could really use the help.
Karl
Reply With Quote
  #5  
Old 09-17-2008, 05:03 PM
Registered User
 
Join Date: Feb 2004
Location: Walnut Creek, CA & 1,150 miles S of Key West
Posts: 4,874
If its doing as you describe, it ought to set new codes pretty quickly.

That info (or lack of same) will help point you in the right direction.
__________________
Terry Allison
N. Calif. & S. of Key West

09' E320 Bluetec 77k
Reply With Quote
  #6  
Old 09-18-2008, 09:19 AM
Registered User
 
Join Date: Aug 2008
Posts: 19
Here are a few posts I have left in the past day or so, if you can help me out at all it would be great.
96 e320
I have a 96 e320 that has been driving me nuts. When I go to start it, it starts and the idle surges a few times before smoothing out, then when I give it some gas it stalls as it approaches 2k rpm. Then when I go to restart sometimes it starts sometimes it starts and stalls right out, any ideas???? It will stumble like its out of gas, but I know that not to be the case.

We changed the battery and alt. and I think that might have reset whatever codes were in there. My problem is I'm afraid to drive it because I don't want to get stuck. I think the codes reset after about 40 miles.

It's my daughter in laws car, and the light was on. My son said it was an egr code but I didn't see it for myself. I pulled the egr valve and put a vacuum check on it and it held, I then cleaned it real good with the valve open and closed and it looked as if it was opening and closing smoothly. Any other ideas? I could really use the help.
Karl

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:03 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page