Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-25-2008, 10:26 AM
Registered User
 
Join Date: Sep 2008
Location: Bloomfield, N.J.
Posts: 26
Cool 95 Sl, OBDII ?

Can a 95 SL use an OBDII reader? "reads only OBDII codes 1996 and later models, which is, with a few exceptions," Just trying to find out if the 95 Sl's are this exception?

Reply With Quote
  #2  
Old 09-25-2008, 11:22 AM
Registered User
 
Join Date: Aug 2003
Location: Phoenix
Posts: 3,726
Yes, 1995 early adopters were C280, SL320 and S320.
Reply With Quote
  #3  
Old 09-25-2008, 12:40 PM
Registered User
 
Join Date: Sep 2008
Location: Bloomfield, N.J.
Posts: 26
Thanks, any suggestions on a good, inexpensive reader?
Reply With Quote
  #4  
Old 09-25-2008, 12:44 PM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
As posted..only on the USA SL320's in 1995. NOT on the SL500 or SL600
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #5  
Old 09-25-2008, 02:45 PM
Registered User
 
Join Date: Sep 2008
Location: Bloomfield, N.J.
Posts: 26
That's great because I opted to buy a SL320 instead of the SL500, again thanks.
Reply With Quote
  #6  
Old 09-25-2008, 03:30 PM
amg280's Avatar
Registered User
 
Join Date: Apr 2002
Location: NY
Posts: 530
My 95 E320 doesnt have an OBD2 port. Ive read posts that 95's were both Analogue and digital. However, I was at my mechanics today and the computer would only work on Analogue mode. When we tried to poll pin 14 or 8 with the digital mode, it would fail to communicate? Is this really a true analogue only system?
__________________
93 300D 2.5 Turbo, Black/Palomino 273K
09 E350 Black/Black 41K
Reply With Quote
  #7  
Old 09-25-2008, 03:31 PM
Registered User
 
Join Date: Aug 2003
Location: Phoenix
Posts: 3,726
Not E's - just C, S and SL 104 motors in 95.
Reply With Quote
  #8  
Old 09-25-2008, 03:33 PM
amg280's Avatar
Registered User
 
Join Date: Apr 2002
Location: NY
Posts: 530
Quote:
Originally Posted by deanyel View Post
Not E's - just C, S and SL 104 motors in 95.
ahh i see. That would explain why it didnt work then...

__________________
93 300D 2.5 Turbo, Black/Palomino 273K
09 E350 Black/Black 41K
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:34 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page