Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-12-2001, 10:56 PM
Posts: n/a
Tick-clack sounds (hamster in the engine?)

Hi everyone,

My w123 is with the M102 engine, and I would like to eradicate the ticking-clicking sound emerging from the engine everytime the accelerator is applied (under load). I know that this issue had been discussed before in other threads but would like to seek some opinons before deciding on the course of action.

I have checked the tappets which are fine, so I'm ruling that out. Now, would the timing chain play a part in this or should I be looking at the piston 'pins' (Major overhaul, *sigh*) or crankshaft bearings (I sure hope not!)

Anyone out there with such experiences?? Many thanks in advance.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
All M104 engine owners, Please Read David C Klasse Tech Help 27 05-31-2010 04:40 PM
Help! Engine Dead???? Breckman99 Diesel Discussion 17 05-09-2005 11:26 PM
engine sounds johnp123 Performance Paddock 15 06-05-2002 03:31 AM
Diesel Engine Break-in Mileage Mercedes Man Diesel Discussion 10 03-21-2002 11:57 PM
300E engine sounds like diesel upon cold start iodyn Tech Help 3 01-09-2002 10:52 AM

All times are GMT -4. The time now is 12:44 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page