Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-11-2008, 12:59 AM
Registered User
 
Join Date: May 2008
Location: San Mateo, CA
Posts: 102
ABS non-operational, no light in dash

Last weekend, I had to brake hard on the road and that's when I realized that the ABS was not working (no pulsing). The ABS light on the dash is off before I start and after I start the car. I searched the forum and most of the posts were for the light being on. Any ideas where to begin to troubleshoot? This is for a 1990 190e 2.6. Thanks!

__________________
---------------------
200 75 W115 (Mom's)
190e 90 2.6 W201
E320 95 Wagon W124
72 BMW 3.0 CSI
Reply With Quote
  #2  
Old 10-11-2008, 01:16 AM
compu_85's Avatar
Cruisin on Electric Ave.
 
Join Date: May 2008
Location: Springfield VA
Posts: 5,202
Has the ABS ever worked? Are you sure there is a lamp installed in the warning light?

-Jason
__________________
1991 350SDL. 230,000 miles (new motor @ 150,000).

Tesla Model 3. 136,000 miles. Been to 48 states!
Past: A fleet of VW TDIs.... including a V10,a Dieselgate Passat, and 2 ECOdiesels.
2014 Cadillac ELR
2013 Fiat 500E.
Reply With Quote
  #3  
Old 10-11-2008, 08:18 PM
Registered User
 
Join Date: May 2008
Location: San Mateo, CA
Posts: 102
I never really noticed it. I have a feeling that the light was never on with the other lights before I started the car. So, I have a feeling that it never worked.
__________________
---------------------
200 75 W115 (Mom's)
190e 90 2.6 W201
E320 95 Wagon W124
72 BMW 3.0 CSI
Reply With Quote
  #4  
Old 10-11-2008, 08:29 PM
Registered User
 
Join Date: Aug 2003
Location: Phoenix
Posts: 3,726
First step would be to get the ABS warning light working, pull the instrument pod and shuffle some bulbs around.
Reply With Quote
  #5  
Old 10-12-2008, 09:40 PM
Registered User
 
Join Date: May 2008
Location: San Mateo, CA
Posts: 102
Cool, I'll start with the bulbs first and will post results.

__________________
---------------------
200 75 W115 (Mom's)
190e 90 2.6 W201
E320 95 Wagon W124
72 BMW 3.0 CSI
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:12 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page