Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-17-2008, 06:24 PM
mespe's Avatar
benzbonz
 
Join Date: Feb 2005
Location: Cleveland, Ohio
Posts: 1,835
1987 190e 2.3 touch the gas pedal and she stalls

Hi,

My daughter's 1987 190e (on it's last wheel) has 262K miles on it. It started stalling while she was driving it, only to restart after one or two attempts. Got progressively worse.

I brought the car into my shop to check it out. Compression # 1 = 120 psi #'2 2&3 = 180 PSI and #4 = 150 PSI. Hadn't changed much in the 18 months that she's been driving it. I now, it's terrible, but this car drove like a bat out of hell when I was driving it,,, suprisingly alot of fun,,, peppy,, well anyway,,,

Vacuum = 14 inches at idle. Can't find any vacuum leaks. 18 months ago I checked the valve timing and it was fine.

I drove the car into the shop, and started fiddling with it, now It barely wants to run, I don't think I cross the combobulator with the spherical axis, but just wanted to start a thread to maybe get some suggestions, and to let you all know what I discovered,,,
__________________
With thousands of Pre-Owned Mercedes parts ready to ship, we are now "mobile friendly" check out
Benzbonz.biz
on your smart phone or tablet.
Reply With Quote
  #2  
Old 11-17-2008, 09:04 PM
Registered User
 
Join Date: Jul 2007
Location: USA
Posts: 2,156
Read up on the fuel injection system and then check sensors and fuel injection componets, I would then check your fuel hoses and see if they are leaking.
__________________
1986 300SDL, 211K,Dealership serviced its whole life
1991 190E 2.6(120k)
1983 300D(300k)
1977 300D(211k)
Reply With Quote
  #3  
Old 11-18-2008, 05:57 PM
mespe's Avatar
benzbonz
 
Join Date: Feb 2005
Location: Cleveland, Ohio
Posts: 1,835
Well of all the stupidist things I've done to date,,, OK some PO broke the OVP relay's connector and it just sits there from the tension of the wiring. I thought I pushed the OVP relay back on good and tight, but guess I didn't. So now the start, cough, sputter stall has magically vanished and I gotta figure out why it flat out dies intermittentantly while driving.
__________________
With thousands of Pre-Owned Mercedes parts ready to ship, we are now "mobile friendly" check out
Benzbonz.biz
on your smart phone or tablet.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:15 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page