Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-09-2009, 05:03 AM
locry's Avatar
I love this place!!! :)
 
Join Date: Nov 2003
Location: Philippines, ...recently submerged, AGAIN
Posts: 1,017
w140 S280 locking pump keeps running @ 20 sec intervals

Help!!!... I just realized that my dad's s280's central locking pump keeps activating in 20 sec or so intervals... locked or unlocked... though nothing actually happens... locks stay as they are... backup antenas stay as they are and even the trunk latch mechanism stay put... they DO WORK properly when triggered... i just hear the pump running under the passenger rear seat... i confirmed it was the pump because the pump was hot.

can a small vacuum leak cause this? does the entire vac system need to maintain a certain pressure or lack thereof? coz if it does then it should be a simple vacuum leak... on the other hand... if it doesn't maintain a certain pressure, what could be activating it?

thanks guys

__________________

85 190E 2.3(SOLD)
86 230E (-->300D)
87 300D (-->300TD)
68 250S w/ a 615 and manual tranny (RIP)
87 300TD (SOLD)
95 S280 "The KRAKEN" (Turbo 2.9 602 transplant)
Reply With Quote
  #2  
Old 01-09-2009, 05:47 AM
Carson357's Avatar
www.stonebrew.com
 
Join Date: Aug 2006
Location: San Diego, California
Posts: 1,116
Quote:
Originally Posted by locry View Post
Help!!!... I just realized that my dad's s280's central locking pump keeps activating in 20 sec or so intervals... locked or unlocked... though nothing actually happens... locks stay as they are... backup antenas stay as they are and even the trunk latch mechanism stay put... they DO WORK properly when triggered... i just hear the pump running under the passenger rear seat... i confirmed it was the pump because the pump was hot.

can a small vacuum leak cause this? does the entire vac system need to maintain a certain pressure or lack thereof? coz if it does then it should be a simple vacuum leak... on the other hand... if it doesn't maintain a certain pressure, what could be activating it?

thanks guys
how is the climate control system? some of the cars use the pse pump(central locking pump) to supplement vacuum to the climate control system when engine vacuum is low, usually it comes on, but should not as frequently as you describe.
what i have seen cause it to act the way yours is usually happens when there is a leaking vacuum control servo in the dash, look at your pump vacuum connections and see if there is a clear vacuum line going to it, usually the supplemental vacuum hose is clear or light in color, i have usually cut the line and plugged both ends and see if this stops the pump from running so often, if it does stop it, keep in mind this is a temporary fix and the leak needs to be properly identified an corrected. and if it is let go the pump will eventually burn up,
__________________
1967 250 S
1967 280SE
1968 250S
1971 280 SE
1973 220
1974 280 S
1975 450 SEL
1976 220 D
1979 300SD
1983 300 SD
1985 230 TE euro
1986 280SL
1986 500 SEL euro
1986 190E 2.3
1990 300 SE
2003 C230 K
2004 C230 K
1987 560SEL
1987 300SDL now in canada
2005 C230
1998 C43 AMG Sold to DON
1993 190E 2.6
300TD Former daily driver Totaled
current:
R320 CDI
Ram 2500 Cummins
Reply With Quote
  #3  
Old 01-09-2009, 06:34 AM
locry's Avatar
I love this place!!! :)
 
Join Date: Nov 2003
Location: Philippines, ...recently submerged, AGAIN
Posts: 1,017
thanks for the speedy reply bro... i do not remember seeing a clear line... i will have to double check though...

offhand do you remember which nozzle the a/c vac lines go to? i remember seeing 2-3 letters per nozzle. thanks
__________________

85 190E 2.3(SOLD)
86 230E (-->300D)
87 300D (-->300TD)
68 250S w/ a 615 and manual tranny (RIP)
87 300TD (SOLD)
95 S280 "The KRAKEN" (Turbo 2.9 602 transplant)
Reply With Quote
  #4  
Old 01-09-2009, 07:59 AM
Member
 
Join Date: Jan 2003
Location: Florida
Posts: 1,084
You must have a leak in either the vacuum line used to supply VAC for HVAC when the engine does not produce any like in REST, or you have a leak in the lumbar section which provides pressure. They both have reservoirs and the pump is replenishing.
Transparent (P-) vacuum
Gray (p-) lumbar
There also could be a bad check valve on the engine side.
Reply With Quote
  #5  
Old 01-11-2009, 12:31 AM
locry's Avatar
I love this place!!! :)
 
Join Date: Nov 2003
Location: Philippines, ...recently submerged, AGAIN
Posts: 1,017
thanks for the reply bro... i temporarily plugged the P- nozzle at the pump and all is well again. never messed with the lumbar thingy anyway...

don't have the time and energy to do a thorough check of the vacuum lines right now... but at least you pointed me in the right direction. thanks guys!

important things are the locks and the trunk.
__________________

85 190E 2.3(SOLD)
86 230E (-->300D)
87 300D (-->300TD)
68 250S w/ a 615 and manual tranny (RIP)
87 300TD (SOLD)
95 S280 "The KRAKEN" (Turbo 2.9 602 transplant)
Reply With Quote
  #6  
Old 01-11-2009, 10:58 AM
babymog's Avatar
Loose Cannon - No Balls
 
Join Date: Jan 2006
Location: Northeast Indiana
Posts: 10,765
The controls for my lumbar/orthopedic seat leaked on my driver's side, the pump burned up. IIRC the pump was around $1400 (dealer).

__________________

Gone to the dark side

- Jeff
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:22 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page