Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-10-2009, 02:54 PM
Registered User
 
Join Date: Aug 2006
Location: London, Ontario, Canada
Posts: 543
94 E420 Wont crank, multifunction relay buzzing.

Hi Guys, Im way out of my league on the E420, I need some serious help.

My 94 E420 makes a loud buzzing noise from the relay in the fuse panel,
PN 201 821 00 47

The car wont crank.

Can anyone recomend where to start.

thanks in advance for the help.

__________________
1984 Euro 300SDC, (4spd standard)
1986 Toyota Landcruiser Diesel HJ60 5spd X2

Gone but not forgotten (some sold, some stripped)
1983 300 SD, 1985 300 SD, 1983 240D, 1986 300 SDL, 1985 300 SDL, 1983 300 D, 1984 300 D, 1985 300SD, 1987 300 SDL, 1983 300 SD, 1985 300 TD Euro, 1983 380SEC, 1990 300 D, 1987 300D, 1982 300D, 1982 300D, 1994 E420, 1987 300 TD, 1987 300 D, 1984 300 D
Reply With Quote
  #2  
Old 01-10-2009, 03:01 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
Check fuse 5
__________________
A Dalton
Reply With Quote
  #3  
Old 01-10-2009, 04:59 PM
Registered User
 
Join Date: Aug 2006
Location: London, Ontario, Canada
Posts: 543
Yep that got her started, thanks.
__________________
1984 Euro 300SDC, (4spd standard)
1986 Toyota Landcruiser Diesel HJ60 5spd X2

Gone but not forgotten (some sold, some stripped)
1983 300 SD, 1985 300 SD, 1983 240D, 1986 300 SDL, 1985 300 SDL, 1983 300 D, 1984 300 D, 1985 300SD, 1987 300 SDL, 1983 300 SD, 1985 300 TD Euro, 1983 380SEC, 1990 300 D, 1987 300D, 1982 300D, 1982 300D, 1994 E420, 1987 300 TD, 1987 300 D, 1984 300 D
Reply With Quote
  #4  
Old 01-10-2009, 06:18 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
You're Welcome...........
__________________
A Dalton
Reply With Quote
  #5  
Old 07-10-2011, 10:12 PM
Registered User
 
Join Date: Jan 2002
Posts: 3,126
This exact answer solved my problem, thank you!

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page