Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-14-2009, 02:28 PM
Registered User
 
Join Date: Jan 2009
Posts: 1
190 e 2.3 heat issues

Guys, i have seen this topic covered in this forum for other models but cant seem to find anyone having the problem on the 190(although i am a computer moron).
The heat is always coming out of the defroster in my merc, the fan control works and i can adjust the fan speed but i can never shut the heat off.
The vents work when i switch to them so its not a "vacuum" problem that i see mentioned so often. The A/C no longer works either. Is there a problem with the ECU or is it somewhere else? Any help woulb be greatly appreciated

Reply With Quote
  #2  
Old 01-14-2009, 03:19 PM
Registered User
 
Join Date: Jul 2001
Location: SoCal
Posts: 1,303
Don't forget the heater valve is also vacuum operated, and with no vacuum, it is 'on'. It is located between the firewalls, under the leaf guard.

Steve

__________________
'91 MB 190E 2.3
'08 RAV4 Ltd 3.5
'83 Lazy Daze m'home 5.7
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page