Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-06-2001, 01:26 PM
aTOMic's Avatar
Join Date: Aug 2001
Location: Hendersonville, Tennessee, USA, Earth
Posts: 451
Anyone tried the Motor Vac?

I did a search, only found one topic relevant. Any input?
RIP "Betsy" (Oo=*=oO)
'96 E 3 2 0 (W 2 1 0) M 1 0 4

Spaces in sig so as not to screw up the SEARCH; every time someone searches for that MB they don't want my sig!

2004 Audi A8L
'98 VW Passat 1.8T 5M
'87 Alfa Romeo Milano 2.5L 5M
'67 Impala convertible, 327cid
Reply With Quote
Old 10-06-2001, 03:15 PM
Registered User
Join Date: Jul 2000
Location: Toronto, CANADA
Posts: 1,193
The dealer used it on my 1986 420SEL last year when I couldn't pass the emmissions test. I had alot of carbon build up and was getting some pre-ignition. Motor vac cleared it up, and I passed emmissions. This really just cures symptoms, it does not fix problems. I don't know if the chemicals are harmful to seals over time or not, but I would warn against using it often. Probably once in the lifetime of the engine is enough.
Jason Priest
1999 E430
1995 E420 - retired
1986 420SEL - retired
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 01:17 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page