Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-31-2009, 11:59 PM
C280 Sport's Avatar
Registered User
 
Join Date: Sep 2008
Location: Saratoga Springs, NY and Sarasota FL
Posts: 152
2000 C280 hard idle and check engine light

Hello I have a 2000 C280 with about 77,000 miles. Today at the stop light the check engine light came on and then the car started to idle very hard. I am guessing this is a MAF sensor? I hear thats common on the W202. Any help would be great.
Reply With Quote
  #2  
Old 02-01-2009, 01:24 AM
pawoSD's Avatar
Dieselsüchtiger
 
Join Date: Oct 2004
Location: Grand Rapids, MI
Posts: 14,861
Sooo....is a C280 sport a reliable and inexpensive vehicle to own? It seems like its always having a problem!

I'd pull the code to find out what the problem is, that should send you in the right direction. Even a place like autozone should be able to read it.
__________________
-diesel is not just a fuel, its a way of life-
'89 420SEL 168k - mine (OC-170,000)
'93 190D 2.2 - 223k - mine (OC-222,700)
'01 E320 Wagon - 149k - mine (OC-154,000)
'05 C240 4matic Wagon - 153k - wifes (OC-154,500)
'01 E320 - 162k - Dad's (OC-163,500)
'07 E350 Wagon - 116k - dad's (OC-121,500)
'02 E320 - 193k - Brother's (OC - 192,000)
'09 E350 4matic Sedan - 84k - Brothers (OC-85,500)
Reply With Quote
  #3  
Old 02-01-2009, 01:51 AM
johnathan1's Avatar
Registered User
 
Join Date: Feb 2008
Location: Downey, SoCal
Posts: 1,169
What does "hard" idle mean? Rough? Pull DTC's and report back.
__________________
Current cars:
2001 ML320, 154k miles
1995 E320, 90k miles
Reply With Quote
  #4  
Old 02-01-2009, 01:55 AM
C280 Sport's Avatar
Registered User
 
Join Date: Sep 2008
Location: Saratoga Springs, NY and Sarasota FL
Posts: 152
Quote:
Originally Posted by pawoSD View Post
Sooo....is a C280 sport a reliable and inexpensive vehicle to own? It seems like its always having a problem!

I'd pull the code to find out what the problem is, that should send you in the right direction. Even a place like autozone should be able to read it.
I have been dissapointed with it since the day I got it actually. I have had no major issues but just lots of stupid little things that can drive you crazy. Its just not the car I thought it was.. It just feels cheap especially the interior. God it awfull.. I am guessing this issue is a MAF sensor. I hope I am right.
Reply With Quote
  #5  
Old 02-01-2009, 01:55 AM
C280 Sport's Avatar
Registered User
 
Join Date: Sep 2008
Location: Saratoga Springs, NY and Sarasota FL
Posts: 152
Quote:
Originally Posted by johnathan1 View Post
What does "hard" idle mean? Rough? Pull DTC's and report back.
Yes it is a rough idle. The car shakes while stopped.
Reply With Quote
  #6  
Old 02-01-2009, 02:24 AM
pawoSD's Avatar
Dieselsüchtiger
 
Join Date: Oct 2004
Location: Grand Rapids, MI
Posts: 14,861
Maybe one of the coils went out or a spark plug is fouled?
__________________
-diesel is not just a fuel, its a way of life-
'89 420SEL 168k - mine (OC-170,000)
'93 190D 2.2 - 223k - mine (OC-222,700)
'01 E320 Wagon - 149k - mine (OC-154,000)
'05 C240 4matic Wagon - 153k - wifes (OC-154,500)
'01 E320 - 162k - Dad's (OC-163,500)
'07 E350 Wagon - 116k - dad's (OC-121,500)
'02 E320 - 193k - Brother's (OC - 192,000)
'09 E350 4matic Sedan - 84k - Brothers (OC-85,500)
Reply With Quote
  #7  
Old 02-01-2009, 03:45 PM
ILUVMILS's Avatar
Senior Member
 
Join Date: Sep 2002
Location: New Jersey, U.S.A.
Posts: 2,461
Quote:
Originally Posted by C280 Sport View Post
......I am guessing this issue is a MAF sensor. I hope I am right.
It sounds more like bad spark plug wires to me. Have the codes checked, don't guess!
__________________
ILUVMILS
MB Shop Foreman
MB Master Technician
MB Master Guild Tehnician 2007
Factory trained in NJ, PA, AL, CA, FLA,
and Germany
27 years and counting!

1994 E320 (wrecked)
2001 E320
2005 C240 4Matic Wagon
2000 E320
2000 ML320
Reply With Quote
  #8  
Old 02-01-2009, 04:08 PM
C280 Sport's Avatar
Registered User
 
Join Date: Sep 2008
Location: Saratoga Springs, NY and Sarasota FL
Posts: 152
Quote:
Originally Posted by ILUVMILS View Post
It sounds more like bad spark plug wires to me. Have the codes checked, don't guess!
No I will not guess. Not with any of my cars. I will get her scanned tomorrow and keep everyone updated.
Reply With Quote
  #9  
Old 02-02-2009, 04:45 AM
Carson357's Avatar
www.stonebrew.com
 
Join Date: Aug 2006
Location: San Diego, California
Posts: 1,114
i have seen a few C280's or other W202 chassis do this when the ov relay is bad or has blown fuse, not 100%, just my $0.02
__________________
1967 250 S
1967 280SE
1968 250S
1971 280 SE
1973 220
1974 280 S
1975 450 SEL
1976 220 D
1979 300SD
1983 300 SD
1985 230 TE euro
1986 280SL
1986 500 SEL euro
1986 190E 2.3
1990 300 SE
2003 C230 K
2004 C230 K
1987 560SEL
1987 300SDL now in canada
2005 C230
1998 C43 AMG Sold to DON
1993 190E 2.6
300TD Former daily driver Totaled
current:
R320 CDI
Ram 2500 Cummins
Reply With Quote
  #10  
Old 02-04-2009, 11:09 PM
Registered User
 
Join Date: Jan 2008
Location: San Diego
Posts: 56
If i remeber, its too new to have a over voltage protection relay. In place has a k40.
Reply With Quote
  #11  
Old 02-05-2009, 10:39 PM
Luther
 
Join Date: Dec 2008
Location: St Petersburg, Fl
Posts: 100
I see you are sporting two addresses, NY & Fl. Does this vehicle set while you are away?
Or did this start when you entered Fl? If you answer YES to both questions, I am sorry to tell you this but your car is suffering from "ERI". "ERI" is not fatal, but has been known to require a complete physical. The doctor usually has to enter through the back side with some alterations being made up front. Recovery time varies, mainly due to the size of the wallet.

"ERI" is spreading across the country at an alarming rate, caution to all gas vehicles.

Feel free to PM me for additional details.

Luther Carrier
St Petersburg, Fl
Reply With Quote
  #12  
Old 02-05-2009, 11:46 PM
C280 Sport's Avatar
Registered User
 
Join Date: Sep 2008
Location: Saratoga Springs, NY and Sarasota FL
Posts: 152
Quote:
Originally Posted by el sea View Post
I see you are sporting two addresses, NY & Fl. Does this vehicle set while you are away?
Or did this start when you entered Fl? If you answer YES to both questions, I am sorry to tell you this but your car is suffering from "ERI". "ERI" is not fatal, but has been known to require a complete physical. The doctor usually has to enter through the back side with some alterations being made up front. Recovery time varies, mainly due to the size of the wallet.

"ERI" is spreading across the country at an alarming rate, caution to all gas vehicles.

Feel free to PM me for additional details.

Luther Carrier
St Petersburg, Fl
The car is with me here in NY. I found the issue a couple days ago. The codes where that it needed 2 new spark plugs. Everything is ok now. Thank you.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page