Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-30-2009, 10:31 AM
Registered User
 
Join Date: Jan 2007
Location: Newville, Pennsylvania
Posts: 4
86 300e seats not working fuses ok

Any suggestions
Reply With Quote
  #2  
Old 03-30-2009, 10:43 AM
Registered User
 
Join Date: Dec 2007
Location: San Diego, CA
Posts: 398
All functions?
__________________
1981 300TD
2005 C55
2004 E500
1999 ML430
1992 400E
1998 C43
2001 SL500
1988 300SEL
1986 190E 16V
1991 190E 2.6
Reply With Quote
  #3  
Old 03-30-2009, 06:50 PM
J.HIDALGO's Avatar
Registered User
 
Join Date: Jul 1999
Location: Jax, FL
Posts: 1,785
Check the connections...

under the seats. Some of them get loose and I am talking about the holes in the female plugs and no...I am not kidding.
I happened to my car!
__________________
J.H.
'86 300E
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:19 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page