Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-03-2009, 10:07 AM
brookspw's Avatar
Registered User
 
Join Date: Dec 2001
Location: Nashville, TN
Posts: 551
Question: fault code on EA on 1994 C280

Had my headgasket replaced. I replaced engine harness last year. Mechanic said the EA wire bundle was crunchy and that it suffered the same problem as the engine harness (the dealer had previously sliced into it without my permission and didn't seal it back up, either, bare wires in there). Other than leaking, it appeared to be running just fine although I had check engine light on.

Once back together it didn't run well, lopey idle and rough running.

Codes showed bad EA and Air Flow meter. I changed the air flow and that helped tremendously. Frankly, it ran as good as before -- seemed perfect to me. But...EA still showed fault.

I found a salvage one on ebay from a 96 wrecked with only 50k miles. Got it cheap. Looked great, wires seemed to be in good shape.

Well, it is faulting, too.

So, here is my question: If the car seems to run fine, good as ever, and gas mileage is good as ever -- what exactly is causing the EA to fault and until/unless the EA worsens why should I even worry about it?

__________________
1994 C280, dark green metallic
105k miles

1991 190E 2.6, Black
191,500 miles
(sold to another forum member)

2003 Chevy Tahoe LT, Redfire Metallic
105k miles

1989 Mustang GT Cobra Convertible
43k miles
Reply With Quote
  #2  
Old 04-03-2009, 11:09 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
What EA code are you getting?? Many codes for items other than the actuator..even the brake lamp switch.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 04-03-2009, 11:33 AM
brookspw's Avatar
Registered User
 
Join Date: Dec 2001
Location: Nashville, TN
Posts: 551
Quote:
Originally Posted by M.B.DOC View Post
What EA code are you getting?? Many codes for items other than the actuator..even the brake lamp switch.
My guy is pulling the codes tomorrow. I'll report back.
__________________
1994 C280, dark green metallic
105k miles

1991 190E 2.6, Black
191,500 miles
(sold to another forum member)

2003 Chevy Tahoe LT, Redfire Metallic
105k miles

1989 Mustang GT Cobra Convertible
43k miles
Reply With Quote
  #4  
Old 04-03-2009, 03:03 PM
david s poole
 
Join Date: Mar 2005
Location: dallas
Posts: 1,822
the wiring leading to and inside the ea will be toast you need to get a rebuilt to fix the problem.
__________________
David S Poole
European Performance
Dallas, TX
4696880422

"Fortune favors the prepared mind"
1987 Mercedes Benz 420SEL
1988 Mercedes Benz 300TE (With new evaporator)
2000 Mercedes Benz C280
http://www.w108.org/gallery/albums/A...1159.thumb.jpg
Reply With Quote
  #5  
Old 04-03-2009, 03:21 PM
brookspw's Avatar
Registered User
 
Join Date: Dec 2001
Location: Nashville, TN
Posts: 551
Quote:
Originally Posted by david s poole View Post
the wiring leading to and inside the ea will be toast you need to get a rebuilt to fix the problem.
Runs fine but I'm going to work on getting one and replacing it in the next couple of months.

__________________
1994 C280, dark green metallic
105k miles

1991 190E 2.6, Black
191,500 miles
(sold to another forum member)

2003 Chevy Tahoe LT, Redfire Metallic
105k miles

1989 Mustang GT Cobra Convertible
43k miles
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 08:04 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page