Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-30-2009, 04:16 PM
Registered User
 
Join Date: Apr 2009
Posts: 1
'99 E320 Climate Control Problems

My Econ light is lit up and the A/C compressor is not engaging. No matter which button I push the econ light stays on and no cooling. I have checked the static pressure in the A/C system and it is ~60 psi so I think the 134a is ok. Any suggestions??
Reply With Quote
  #2  
Old 04-30-2009, 07:32 PM
Registered User
 
Join Date: Oct 2004
Posts: 2,886
You don't have enough refrigerant. More importantly....Why?
__________________
90 300TE 4-Matic

Turbo 103 4-Matic, 3 cam advance
11-18 PSI, A2W I/C, 40 LB/HR
MS II Extra, 60-2 Direct Coil Control
3" Exhaust, AEM W/B O2
Underdrive Alt. and P/S Pulleys,
Vented Rear Brake Discs, .034 Booster.
3.07 Front and Rear Diff, 1st Gear Start

91 300CE parting

90 300CE 104.980
Milled & ported head, 10.3:1 compression
197 intake cam w/20 advancer
4 ignition advance
PCS TCM2000 running 722.6 trans, 600W PWM fan, water injection
Reply With Quote
  #3  
Old 05-01-2009, 10:33 AM
Registered User
 
Join Date: Oct 2005
Posts: 4,263
It could be refrigerant, or it could be the evaporator temperature sensor, or the clutch. Or a few other things.

Search for the instructions to extract the current sensor values and trouble codes. Static pressure tells you nothing.
Reply With Quote
  #4  
Old 05-02-2009, 07:11 AM
Hirnbeiss's Avatar
ich fahre, also bin ich
 
Join Date: Mar 2002
Location: South Florida
Posts: 1,600
http://www.eclassbenz.com/node/27#comment
__________________
Prost!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:54 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page