Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-23-2001, 09:24 AM
Registered User
Join Date: Aug 2001
Location: Florida
Posts: 270
update** suddenly very bad running 400E..missing and clicking at the coil

Hey guys. HELP..1992....91000 k after a week of being parked I started the started great...drove it 4 miles or so on the open hiway..let off the gas the car started missing warning lights
and it is still running badly. It sort of did it a little a couple of weeks ago just like it has a tank of bad gas. It is almost cycling like it's trying to even out but there is a clicking under the hood at the coil at an item that is on the coil but I'm not sure it's the coil itself. Any help would be great.

Last edited by Bzoo; 10-23-2001 at 02:48 PM.
Reply With Quote
Old 10-23-2001, 02:49 PM
Registered User
Join Date: Aug 2001
Location: Florida
Posts: 270
Parked the car...locked the door...came back 3 hrs later and the car runs like a wiring harness in april by the way.
Reply With Quote
Old 10-23-2001, 08:49 PM
Posts: n/a
It sounds like you definetly have a electrical problem. And it seems that it willbe easy enough to figure out. My suggesttion is that if it starts acting up again like you described you need to get the car into a dark area and open the hood and look in the area where the clicking is coming from. You should see some sparking where the noise is coming from. Also depending how brave you are you may want to start the car up and get under the hood and star moving some wires around ithat general area and even give the coil a a slight tap or 2 so you maybe able to isolate the problem in your driveway rather than having it strand you on the road. Oh my first thought when I read the post was a plug wire or coil wire maybe loose or something. anyways I hope this helps good luck and keep us posted
Reply With Quote
Old 10-23-2001, 09:09 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
The most common thing on this is the distributor caps and rotors. I have replaced quite a few. Look in the DIY section for pics of fautly caps and rotors.
Donnie Drummonds
Reply With Quote
Old 10-24-2001, 09:02 AM
Registered User
Join Date: Aug 2001
Location: Florida
Posts: 270
Thanks for your input.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 12:08 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page