Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-23-2001, 10:25 PM
Registered User
 
Join Date: Jan 2001
Location: Tucson, Arizona
Posts: 758
Courtesy light on headliner rail inop, Any ideas?

Greetings All,

This post is for a '86 300E with a four position courtesy light in the headliner front rail. All the positions of lighting work except to have the light on when you open the door. The door to ground lights work but the overhead doesn't. Any ideas if it can be fixed or what I should be looking for? I keep thinking the time delay is fried and won't let power through. Am I guessing right or not?


Charles
__________________
"Tell me and I will listen, Teach me and I will learn, Show me and I will accomplish, Involve me and I will succeed."
'84 300SD 256,000 Gold on Brown (Mileage Award)
'86 300E 246,000 Blue on Tan
Reply With Quote
  #2  
Old 10-24-2001, 01:58 PM
jbaj007's Avatar
Registered User
 
Join Date: Jun 2001
Location: Santa Monica, CA
Posts: 2,053
I have the same problem (AGAIN) and a replacement light assembly has fixed it in the past. Bumping this in the hope that someone has resoldered the circuit board (like on the CC and the PCU for Climate control) and had it work. Darn German cold solder joints. 300SD 126
__________________
The Golden Rule

1984 300SD (bought new, sold it in 1988, bought it back 13 yrs. later)

Last edited by jbaj007; 10-24-2001 at 04:24 PM.
Reply With Quote
  #3  
Old 10-24-2001, 10:17 PM
Registered User
 
Join Date: Jan 2001
Location: Tucson, Arizona
Posts: 758
Is your coutesy light the same as mine?

Greetings,

Just wondering if you just have a courtesy light or if it's similar to mine. I have a four position switch as follows door contact, on always, map light, and off. I understand that there is a time delay on the door contact part of the switch, which has me wondering if that's not the problem. I can't see a way to get inside the unit itself to resolder all the connections, so if you have done this please provide the secret. I really don't feel like spending $76.00 for a new one because of this problem, and just assume fix this one or if the light is not the problem but is located elsewhere, to fix that instead.

Thanks,

Charles
__________________
"Tell me and I will listen, Teach me and I will learn, Show me and I will accomplish, Involve me and I will succeed."
'84 300SD 256,000 Gold on Brown (Mileage Award)
'86 300E 246,000 Blue on Tan
Reply With Quote
  #4  
Old 10-25-2001, 12:25 PM
jbaj007's Avatar
Registered User
 
Join Date: Jun 2001
Location: Santa Monica, CA
Posts: 2,053
I believe the time delay circuit is the PCB that is in the four position LIGHT, not the door switch. Whether someone has repaired that PCB(printed circuit board) using the resolder technique popular for climate control, that is the question.
__________________
The Golden Rule

1984 300SD (bought new, sold it in 1988, bought it back 13 yrs. later)
Reply With Quote
  #5  
Old 10-26-2001, 01:55 AM
Registered User
 
Join Date: Jan 2001
Location: Tucson, Arizona
Posts: 758
Maybe I wrote it wrong

Greetings,

I figured the time delay was on the pcb and what I meant to say was the position of the overhead switch was set that allowed the door contact switch to operate the light when opening. What I don't know is whether it would affect the light coming on at all. Shouldn't the time delay start doing it's work after the door contact switch has been pushed in like closing the door, otherwise the timer would count out it's time and shut off the light regardless whether you shut the door or not. I wish a tech would chime in and shed some light onto this seemly easly problem.

Charles
__________________
"Tell me and I will listen, Teach me and I will learn, Show me and I will accomplish, Involve me and I will succeed."
'84 300SD 256,000 Gold on Brown (Mileage Award)
'86 300E 246,000 Blue on Tan
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem: The oil pressure light stays on toka Tech Help 4 11-22-2008 05:44 PM
Why is my "you have a light out" idiot light flashing? brookspw Tech Help 3 02-23-2004 02:20 PM
Check Engine Light 96C280 Tech Help 21 05-23-2003 02:48 PM
Rear Fog light. Help please! Bazzman Tech Help 2 03-30-2003 04:33 AM
Headliner courtesy light inop, please help! can-do Tech Help 6 11-01-2001 08:49 PM



All times are GMT -4. The time now is 06:03 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page