Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-31-2001, 01:27 AM
Registered User
 
Join Date: Mar 2000
Posts: 529
'98 C230 - Poor Driveability

'98 C230, impeccably maintained, with 35K miles is exhibiting worsening bouts of poor driveability, with increasing frequency. Occurs only after the engine is fully warmed.

Without warning, the engine will suddenly become poorly responsive to accelerator pedal input - engine just sort of stumbles, then revs, without a corresponding power output. The engine never stalls and the problem typically clears within a minute but can always be cleared by turning off the engine and restarting.

The vehicle has been to the dealer twice in the last six weeks but they state no active or stored fault codes are found and decline to render service until a fault is found. However, the problem's intensity is worsening and has now become a safety issue.

Any thoughts - mass flow sensor? 722.6 transmission control module?

TIA
Reply With Quote
  #2  
Old 10-31-2001, 09:02 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
These are all symptoms of a lean fuel mixture causes by low fuel pressure or a defective air-mass sensor.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 11-05-2001, 01:21 AM
Registered User
 
Join Date: Mar 2000
Posts: 529
After fourth visit in three months for the same complaint....dealer replaced electronic transmission control module, free of charge, although vehicle was out of warranty.

Allegedly, no faults codes were ever found......
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
C230 front brakes - tech quest kim Langley Tech Help 6 10-08-2004 07:34 PM
Ford Taurus compressor; 300e evaporator failure; c230 AuctorEcclesiae Off-Topic Discussion 0 11-22-2003 04:53 PM
W140 v. W202 v. late W124? Which one is better? DieselHead Off-Topic Discussion 31 04-06-2003 02:34 PM
C230 Super Charger FLANDERS Tech Help 2 09-16-2002 06:56 PM
C230 headers? BigPimpin Performance Paddock 4 05-09-2002 12:10 AM



All times are GMT -4. The time now is 04:47 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page