Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-12-2009, 10:42 AM
Registered User
 
Join Date: Jun 2004
Location: Toronto, Canada
Posts: 27
300E A\C not working

I am not getting cold air. The temp control wheel works for hotter air and cooler but no ac.
The compressor clutch engages and works continuously when the dash climate control is turned on and there is 134 in the system with a guage reading of 45 PSI.
This car was converted by a dealer to r 134 approx 11 years ago. Also heat etc and vents appear to be working fine when changing contol setting. Any help would be appreciated of where to start.

__________________
Walter Sawczak
1990 300 E
1993 Lincoln Mark VIII
1983 Jaguar XJ6
Reply With Quote
  #2  
Old 07-12-2009, 11:01 AM
Registered User
 
Join Date: Oct 2005
Posts: 4,263
What's the high-side pressure reading?
Reply With Quote
  #3  
Old 07-12-2009, 11:18 AM
Registered User
 
Join Date: May 2009
Posts: 398
Is the low speed fan coming on? Could be the red sensor on the drier. Is it no cold at all? That could be the blend door inside the unit. The doors and flaps are controlled by vacuum pods that could be going out on you also.

I am betting on the blend door if you say the compressor is engaging as that is normally the first thing that doesn't happen. If you were too high pressure in the system the compressor disengages, and if too low same thing.

Did you put in a new aftermarket radio lately? The vacuum hose for the center area is right behind the radio and A/C control.

Good luck hopefully gives you some ideas.
Reply With Quote
  #4  
Old 07-12-2009, 11:36 AM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
>

Static or running pressure ???????????

If static, it is low on refrig.

If running, then See post #2.

__________________
A Dalton
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:08 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2024 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page