Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-01-2001, 11:46 PM
Posts: n/a
White smoke.

My relay went out as many of you prob know, and I changed that and the fuel pump. The car is running fine now except for a whole lot of white snoke. The car did sit for a few weeks, does anybody know what the smke is all about?
Reply With Quote
Old 11-02-2001, 12:24 AM
David C Klasse's Avatar
CheFrac is Back!
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352
I believe that is the symptom of a bad head gasket.
You should do a search... here are results I got for "white smoke."

Good luck!
2006 E350 w/ 155k miles (Daily Driver)

1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote
Old 11-02-2001, 09:18 AM
Posts: n/a
The last time I saw white smoke coming out the exhaust of one of my cars it had a slight sweet smell to it and it turned out to be antifreeze blowing past the intake manifold (not a MB car though)
Reply With Quote
Old 11-02-2001, 09:21 AM
Posts: n/a
Does the white smoke continue after warm up, or is it only when cold. It might only be condensation. Remember the weather is getting a little cooler now.

Have a great day,
Reply With Quote
Old 11-02-2001, 09:54 AM
Posts: n/a
For some reason it has just stopped. I just replaced the fuel pump and the relay, and it had been sitting for about a month. But I started it this morning and let it run for about a half an hour, and there is no trace of it anymore. It was pouring out, and I mean bad, but it had been sitting, and I had poured some fuel into the intake to get it to start sever al times, but like I said now there is no trace of it....I am baffled!
Reply With Quote
Old 11-02-2001, 10:27 AM
Posts: n/a
I would expect that it was only condensation and possibly a little excess fuel from the priming burning off.

Drive and enjoy with no worry.

Have a great day,
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
help just white smoke on 500sec engine striper Tech Help 3 05-24-2004 05:44 PM
280SE 3.5 white smoke only while warming up jniven Tech Help 8 08-08-2003 12:32 AM
Help, Slight White Smoke Out Of My Exhaust!!! mike690003 Tech Help 10 06-30-2003 11:43 PM
White smoke from exhaust, burning oil ArizonaDAK Tech Help 7 05-11-2002 10:44 AM
white smoke from under the hood. emilo Tech Help 8 04-03-2001 03:56 AM

All times are GMT -4. The time now is 12:07 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page