Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-06-2001, 10:04 PM
Posts: n/a
Electrical Problems Need Help

1988 Mercedes 420 SEL ......gauges do not function, if you tap the multi function relay, part #201 821 00 47, the gauges will respond. I replaced the relay with a new one, however, the gauges still does not work. There is also a clicking sound in the drivers door. Any hint on what else could be causing this problem. Thank you.

Ralph LaFerrara
Reply With Quote
Old 11-06-2001, 11:00 PM
Senior Member
Join Date: Mar 2001
Location: Accokeek, MD
Posts: 683
Are you talking about a relay in the fuse box? If so you may have a corroded fuses. Try cleaning the tips of the fuses and the the clips that hold them in place.

1993 190E 2.3
2000 Toyota 4x4 Tundra
Reply With Quote
Old 11-07-2001, 01:06 AM
Registered User
Join Date: Oct 2001
Location: Hemet, CA
Posts: 36
Laurel: Does the clicking sound happen when the door is open? My car does the same thing and I have no idea what it is! Even with the key not in it or anything turned on, it does it. I couldn't tell if it was coming from the door or under the dash right by the door. I hope somebody knows!

Reply With Quote
Old 11-07-2001, 09:44 AM
ebennz's Avatar
Join Date: Nov 2000
Location: Hurricane, West Virginia
Posts: 878


have you checked all your fuses?
sometimes they may look o.k. but have a hairline crack in them,
it's cheap, and may be worth a shot.

*92 400e 124.034, SOLD

*92 300e 124.030, SOLD
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical problems 1987 560 sel American28 Tech Help 1 06-07-2004 11:57 AM
Electrical Problems WaveRunr Tech Help 1 03-02-2004 06:31 PM
Need help with 560SL electrical problems Solarlady SL Forum 3 10-02-2003 01:17 AM
1995 C280 Electrical Problems David C Klasse Tech Help 14 04-14-2003 08:31 PM
1999 E300D Electrical Problems searaypaul Diesel Discussion 11 05-10-2002 05:52 PM

All times are GMT -4. The time now is 07:00 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page