Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-07-2001, 06:26 PM
Registered User
Join Date: Mar 2001
Location: SF
Posts: 201
86 M103 Oxy Sensor Check

I am wondering if the way to check the Lambda in my 86 300E % speed is like the 190E I already have. If I can recall, Terminal 3 @ X/11 is the one. I have 12.3 volts there and 36% Dwell for duty cycly, hot at Idle 700rpm. I checked because the Idle has been hunting a bit. From 1300RPM Cold to 650 Hot and ocasionally 900 hot. I checked the OVP and cleaned the speed signal wire terminals on the right fender well, any thing else to check? Thanks again!
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Those with M102 & M103 "free power upgrade" must read! Greg in Oz Tech Help 19 05-30-2011 10:44 AM
M103 Oil leak or burning? lino Tech Help 111 11-03-2005 07:18 AM
W124 M103 vs W126 M103 head bolt tightening torque sixto Tech Help 0 07-03-2003 08:44 PM
M103 or M104 Long Term Ownership Experiences? Chris Blanchard Tech Help 12 10-27-2002 07:19 AM
K&N Performance Air Filter for 300E 260E and 190E 2.6 M103 FA22 Mercedes Used Parts For Sale & Wanted 1 09-16-2002 09:42 PM

All times are GMT -4. The time now is 07:32 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page