Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-16-2009, 05:35 PM
Registered User
 
Join Date: Sep 2009
Posts: 2
Question ELECTRICAL PROBLEM 93 300E (HELP)

I have a 1993 2.8 300e with a no start problem. It does not have juice to the starter, no to the neutral safety switch. I traced the starter excite wire and jumped it with a jumper wire and the car starts. But there is a buzzing sound coming from inside the fuse panels relay portion, I checked and it's the long middle relay marked DOT, but will stop when either the turn signals or the 4 way flashers are on or this fuse is removed. Also the fuel gage does not register.
Can this be an ignition switch?
Thank You

Reply With Quote
  #2  
Old 09-17-2009, 08:06 AM
Registered User
 
Join Date: Sep 2009
Posts: 2
Lightbulb Found problem

Well,
I fell like a total idiot, this ended up being a fuse. All the fuses looked good, however when I took and actually removed it - it had a small split (not blown) directly across the middle and of coarse was not making contact. This is a lesson - CHECK ALL FUSES even if they look good.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 08:05 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page