Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-08-2001, 11:42 PM
Snow bum
Join Date: Jan 2001
Location: Here and there . . .
Posts: 238
Strange electrical problem

I walked out to my 300D this evening and noticed that my antenna mast was up even though the car and the radio had been turned off for over an hour. I also noticed that upon opening my back door that the rear interior light does not work. The door lights do work.

This led me to check the fuse box, and both the antenna and the light seem to be on the same fuse. The fuse is fine. I opened the trunk to check the trunk light, since the trunk is on the same fuse, and it was on but very dim. This suggests that at least some current is getting to it.

Does anybody have any idea why these things are happening?

The MBs:
1976 300D (W115) - 330K and still going (sort of)
1991 300D 2.5 Turbo - Sold at 221K
1983 280SEL - Sold at 206K
1981 300SD - Sold at 232K
Reply With Quote
Old 11-09-2001, 10:06 AM
Posts: n/a
A suggestion:

Remove the old fuse, burnish the contacts in the fuse box (using either a nonconductive material, or disconnect the battery first) and install a brand new fuse. Don't let the appearance of the old fuse lull you into a sense of security. They can go bad without completely failing. If you have the time and a few bucks, it wouldn't be a bad idea to burnish all of the contacts in the fuse box and replace ALL fuses as a preventative measure.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
'97 e300d strange intermittant starting problem jessie_eaton Diesel Discussion 13 01-14-2005 08:45 AM
Strange charging/electrical problem GregS Diesel Discussion 16 10-20-2004 06:57 PM
Strange Light Problem '92 MB 500 SL Shanevauctions Tech Help 1 09-10-2004 05:35 PM
Strange heat problem in W126 Omega Tech Help 1 01-04-2002 01:04 AM
electrical problem? Mercedes Fred Tech Help 4 09-24-2001 12:51 PM

All times are GMT -4. The time now is 04:45 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page