Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-04-2009, 12:26 AM
Registered User
 
Join Date: Nov 2004
Location: Dallas, TX
Posts: 5,017
I bought my first W126 in the dark with 230,000 miles and expired tags

Gang, this is my first W126 but not my first Mercedes. I bought it as I sold my 1997 E420 to a friend and thought I would have a commuter vehicle that I can put on my regular insurance.

It's a 1991 560SEL that was very cheap. It's white with gray interior, i'm not sure of the condition because I bought it in the dark, but after replacing the battery (which I bought with me). It started and idled without any scary sounds.

The rear end was sitting level but was stiff so I suspect that the air cells will need replacing. The seller indicated that the a/c compressor is not engaging. I will put my A/C guages on it and see if there is decent pressure.

A couple of issues that I noticed was that the ABS light on constantly and the car idled at around 12-1500 RPM. The transmission had hard shifts when moving from park to drive (probably because of the high RPM) and it needed brake rotors which were very warped

The wiper also ran only on high speed and would not park by itself when you turn it off.

I was able to drive 80 miles to my home from the sellers house to mine in the rain without incident and the car behaved well at speeds, but not as fast as I expected, especially compared to a Euro 500SEL that I drove recently. I know that they have around the same HP so I was expecting the same delivery.

I will have more information tomorrow when I look at the car in the daylight but I would be grateful if someone could point me towards what may be the issue with the high idle, ABS light and wiper motor.

Many thanks!

__________________
With best regards

Al
Reply With Quote
  #2  
Old 10-04-2009, 10:11 AM
bsmuwk's Avatar
124.051
 
Join Date: Jan 2009
Location: IL / WI
Posts: 953
The OVP relay may be at fault for that ABS light and higher idle.
__________________
-Allen
Lakemoor, IL
Artisan Motorenbau
Chicagoland Mercedes Enthusiast Facebook Group: https://www.facebook.com/groups/mbclubchicago/
Reply With Quote
  #3  
Old 10-04-2009, 11:14 AM
ps2cho's Avatar
Registered User
 
Join Date: Jun 2006
Location: Chandler, Arizona
Posts: 3,523
As for wipers, if it is anything like the W124 setup, find the combination relay for it and do some resoldering on the board. It should fix that up very quickly without you spending any money (assuming you have a soldering iron. Any size).
__________________
2016 Monsoon Gray Audi Allroad - 21k
2008 Black Mercedes E350 4Matic Sport - 131k
2014 Jeep Wranger Unlimited Sahara - 62k
2003 Gray Mercedes ML350 - 122k
Reply With Quote
  #4  
Old 10-04-2009, 11:17 AM
Registered User
 
Join Date: Nov 2004
Location: Dallas, TX
Posts: 5,017
The relay is around $40 new. Is it soldered on or just a plug in?

Many thanks!
__________________
With best regards

Al
Reply With Quote
  #5  
Old 10-04-2009, 11:22 AM
ps2cho's Avatar
Registered User
 
Join Date: Jun 2006
Location: Chandler, Arizona
Posts: 3,523
Quote:
Originally Posted by alabbasi View Post
The relay is around $40 new. Is it soldered on or just a plug in?

Many thanks!
Should be a plug in. So just pop her out, get the cover off and check for any burnt or broken points. Just touch em up and test. You should notice a difference right away.

__________________
2016 Monsoon Gray Audi Allroad - 21k
2008 Black Mercedes E350 4Matic Sport - 131k
2014 Jeep Wranger Unlimited Sahara - 62k
2003 Gray Mercedes ML350 - 122k
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page